Extraire plusieurs chaîne de carractères excel

Résolu/Fermé
Signaler
-
Messages postés
26317
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
6 décembre 2021
-
Bonjour,
Je cherche à extraire plusieurs chaînes de caractère dans une colonne et je bloque.Puis je avfoir une formule excel recherche v ou trouve ou un code vBA?
Merci
ci dessous l'exemple:

colonne A Colone B COLONNE C
TEXTE valeur cherché valeur à afficher

MANGE ang ANG
PAPA pa PA
DANSE dan DAN
RECEPTION recept RECEPT
VOISIN ISIN ISIN

7 réponses

Messages postés
26317
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
6 décembre 2021
6 134
Bonjour
=SI(NB.SI(A1;"*"&B1&"*");MAJUSCULE(B1);"")
attention aux signes
crdlmnt
Bonjour,


excuse moi j'ai pas été précis
si la colonne A contient "ange" afficher en colonne B "ange"
si...
j'ai 100000 ligne

colonne A TEXTE Colonne B valeur à afficher

MANGE " ange"
Papas "pas"
DANSE "dan"
Recel "recel"
VOISIN "Si"
Messages postés
26317
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
6 décembre 2021
6 134
Dites nous quel est le rapport entre la valeur en A et la valeur à trouver? là, c'est incompréhensible! c'est un nombre de caractères, une liste de référence, ou quoi?
Messages postés
2679
Date d'inscription
vendredi 25 juillet 2014
Statut
Membre
Dernière intervention
6 décembre 2021
1 241
Bonjour
pas bien compris le but
une proposition quand même
Merci pour ton retour
je cherche une certain nombre de chaine dans des celules.

si la formule retrouve une de ces chaines qu'il l'affiche dans la colonne B

LISTE DES CHAINES A RETROUVER DANS LA CELULE(HEURES CHIFFRE;COUT.VENTE..)

COLONE A COLONE B

L10-HEURES HEURES
L674-HEURES-4 HEURES
L7892425-CHIFFRE CHIFFRE
L7892425-COUT COUT
L25-VENTE-PA VENTE
Messages postés
2679
Date d'inscription
vendredi 25 juillet 2014
Statut
Membre
Dernière intervention
6 décembre 2021
1 241
Re
Une autre proposition
Ici
impossible de voir le lien
Messages postés
2679
Date d'inscription
vendredi 25 juillet 2014
Statut
Membre
Dernière intervention
6 décembre 2021
1 241
Re copie écran
Messages postés
2679
Date d'inscription
vendredi 25 juillet 2014
Statut
Membre
Dernière intervention
6 décembre 2021
1 241
en C3
=SI(ESTERREUR(TROUVE(MAJUSCULE($C$2);A3));"";TROUVE(MAJUSCULE($C$2);A3))

en G3
=SI(C3="";"";STXT($A3;C3;NBCAR(G$2)))
Messages postés
26317
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
6 décembre 2021
6 134
Bonjour
voyez si ce modèle correspond à ce que vous cherchez, et revenez si besoin de complément d'infos

https://www.cjoint.com/c/FIqn2JldUOc

crdlmnt