Critère texte sur 2 colonnes

Résolu/Fermé
StefG - 25 août 2016 à 14:25
 StefG - 25 août 2016 à 14:48
Bonjour,

J'ai pas mal écumé les forums mais impossible de trouver une réponse qui fonctionne sur mon tableau que voici :

Col.A Col.B
X Y
Y Z
Z

Je voudrais connaître le nombre de cellules vides dans la colonne B, à condition que la colonne A ne soit pas vide. A savoir que les colonnes en question sont sur une autre feuille du fichier.

J'ai tenté ceci :
=NB.SI.ENS('Feuille1'!A2:A1001;NON(ESTVIDE); ['Feuille1'!F2:F1001;ESTVIDE])
mais cela ne fonctionne pas, Excel me signale une erreur et surligne ceci : ['Feuille1'

Merci d'avance à ceux qui pourront m'aider !

Stef

1 réponse

Vaucluse Messages postés 26495 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 8 avril 2022 6 283
Modifié par Vaucluse le 25/08/2016 à 14:40
Bonjour

essayez avec:

=NB.SI.ENS(Feuille1!A2:A1001;"<>";Feuille1!F2:F1001;"")

fonctionne si A2:A1001 sont réellement vide

S'il s'agit de formules qui renvoient "", elles ne sont pas vides et il faut inverser les signes "<>" devient "><" pour ne prendre en compte que les résultats de formules différentes de ""
crdlmnt

La qualité de la réponse dépend surtout de la clarté de la question, merci!
0
Nickel, ça fonctionne, merci beaucoup !!!
0