Somme si dans mois donné jusqu'à la date d'aujourd'hui

[Fermé]
Signaler
-
Messages postés
5639
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
22 septembre 2021
-
Bonjour,

J'aimerais calculer sur Excel la somme de mes ventes dans le mois en cours jusqu'à aujourd'hui.
Par exemple, mes ventes dans le mois d'août depuis le 1er jusqu'à aujourd'hui, le 18.
J'ai une colonne A avec les jours du mois (ex: lundi 1er août) et une colonne B avec les ventes du jours correspondant.
J'ai tous les mois de l'année sur mon Excel pas seulement le mois d'Août.
Merci beaucoup pour votre aide !
Aurore

2 réponses

Messages postés
5639
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
22 septembre 2021
651
Bonjour

Essayer cette formule

=SOMME.SI(A1:A31;"<="&AUJOURDHUI();B1:B31)
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 42674 internautes nous ont dit merci ce mois-ci

Messages postés
26192
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
22 septembre 2021
6 061
Bonjour

et bonjour Philou

Ce n'est peut être pas ce qu'attend autorecl si on prend en compte sa remarque: j'ai tous les mois de l'année dans mon Excel.

Du moins ça ne fonctionnera pas si tous les mois sont dans la même liste

Voir éventuellement avec par exemple si les dates sont en A1:A1000 et les montants en B1:B1000

=SOMMEPROD(MOIS(A1:A1000)=MOIS(AUJOURDHUI())*(B1:B1000))

crdllmnt
La qualité de la réponse dépend surtout de la clarté de la question, merci!
Messages postés
5639
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
22 septembre 2021
651
Bonjour Vaucluse j'ai considéré que chaque mois était sur une feuille différente

Voici la formule avec les mois sur une unique colonne

=SOMME.SI.ENS(B1:B380;A1:A380;">="&DATE(ANNEE(AUJOURDHUI());MOIS(AUJOURDHUI());1);A1:A380;"<="&AUJOURDHUI())