Appliquer une formule sur 3 colonnes

Résolu/Fermé
nonossov Messages postés 611 Date d'inscription lundi 29 décembre 2014 Statut Membre Dernière intervention 17 janvier 2020 - 5 août 2016 à 11:21
Gyrus Messages postés 3334 Date d'inscription samedi 20 juillet 2013 Statut Membre Dernière intervention 9 décembre 2016 - 6 août 2016 à 20:28
Bonjour Mes amis,

J'ai besoin de votre aide pour developper une formule , Je veux appliquer cette formule sur trois colonnes A et B et C:

=SI(ET(NBCAR(A1)=9;OU(GAUCHE(A1;1)="6";GAUCHE(A1;1)="7"));"VRAI";"FAUX")

La formule determine le nombre de caractère =9 et il commence par 6, c'est un N° de Tél.


A voir également:

2 réponses

Gyrus Messages postés 3334 Date d'inscription samedi 20 juillet 2013 Statut Membre Dernière intervention 9 décembre 2016 534
5 août 2016 à 12:14
Bonjour,

=ET(ET(OU(GAUCHE(A1;1)="6";GAUCHE(A1;1)="7");NBCAR(A1)=9);ET(OU(GAUCHE(B1;1)="6";GAUCHE(B1;1)="7");NBCAR(B1)=9);ET(OU(GAUCHE(C1;1)="6";GAUCHE(C1;1)="7");NBCAR(C1)=9))

A+
2
nonossov Messages postés 611 Date d'inscription lundi 29 décembre 2014 Statut Membre Dernière intervention 17 janvier 2020 1
6 août 2016 à 14:15
Merci Mr Gyrus, pardon moi j'ai oublié de montionner que meme la cellule et vide je dois avoir VRAI, soit A ou B ou C sont vides?

Merci
0
Gyrus Messages postés 3334 Date d'inscription samedi 20 juillet 2013 Statut Membre Dernière intervention 9 décembre 2016 534 > nonossov Messages postés 611 Date d'inscription lundi 29 décembre 2014 Statut Membre Dernière intervention 17 janvier 2020
6 août 2016 à 20:28
Avec la même logique :
=ET(OU(ET(OU(GAUCHE(A1;1)="6";GAUCHE(A1;1)="7");NBCAR(A1)=9);ESTVIDE(A1));OU(ET(OU(GAUCHE(B1;1)="6";GAUCHE(B1;1)="7");NBCAR(B1)=9);ESTVIDE(B1));OU(ET(OU(GAUCHE(C1;1)="6";GAUCHE(C1;1)="7");NBCAR(C1)=9);ESTVIDE(C1)))

A+
0
Mike-31 Messages postés 18114 Date d'inscription dimanche 17 février 2008 Statut Contributeur Dernière intervention 4 décembre 2022 5 017
Modifié par Mike-31 le 5/08/2016 à 11:40
Bonjour,

Si dans les trois colonnes tu veux tester la même cellule soit A1, il suffit de mettre A1 en référence absolue comme cela
$A$1

=SI(ET(NBCAR($A$1)=9;OU(GAUCHE($A$1;1)="6";GAUCHE($A$1;1)="7"));"VRAI";"FAUX")
et tu incrémentes vers la droite

par contre si tu dois incrémenter vers la droite et vers le bas
il faut simplement un dollar à gauche
=SI(ET(NBCAR($A1)=9;OU(GAUCHE($A1;1)="6";GAUCHE($A1;1)="7"));"VRAI";"FAUX")


A+
Mike-31

Une période d'échec est un moment rêvé pour semer les graines du savoir.
1
nonossov Messages postés 611 Date d'inscription lundi 29 décembre 2014 Statut Membre Dernière intervention 17 janvier 2020 1
5 août 2016 à 11:39
Non Mr Mike,

Je veux savoir c'est les trois colonnes A et B et C respectent les conditions dans la fromules, il faut que A et B et C commence soit par 6 ou 7 et ils ont 9 caractères,

si l'un des colonnes ne respecte pas la condition Alors FAUX,

Merci infiniment pour votre aide
0