Framework version ?? [Résolu/Fermé]

Signaler
Messages postés
45
Date d'inscription
mercredi 21 juillet 2010
Statut
Membre
Dernière intervention
14 avril 2020
-
Messages postés
45
Date d'inscription
mercredi 21 juillet 2010
Statut
Membre
Dernière intervention
14 avril 2020
-
Bonjour,

pour la première fois aujourd'hui, je suis invité au démarrage, à télécharger et installer Framework 2.0.
Lorsque je me rends sur le site de téléchargement, je suis invité à choisir parmi trois versions : NetFx20SP2_x86.exe, _ia64.exe et _x64.exe.

1ère question : je suis sous Win10 avec des versions de programmes récentes ou en tout cas pré-installées. Pourquoi me demande-t-il d'installer la version 2.0 alors qu'au moins la version 4.1 est déjà d'application ?

2e question : s'il faut passer par cette version 2.0, le SP2 est-il de rigueur (je suppose que oui) mais surtout quel choix parmi les trois propositions ?

3e question : faut-il se satisfaire de la version 2.0 ? C'est-à-dire : faut-il aussi installer la dernière version pour des programmes plus récents ou attendre qu'il me le demande ?

Je vous remercie pour vos bons conseils.

3 réponses

Messages postés
45
Date d'inscription
mercredi 21 juillet 2010
Statut
Membre
Dernière intervention
14 avril 2020

Merci pour ce conseil.
Il n'est pas toujours aisé de savoir si, par mégarde, on a téléchargé un Trojan. Je scanne régulièrement à cet effet et il n'y a rien pour l'instant.

Je viens par ailleurs de réinstaller, il y a 2 jours, une imprimante "Tout en un" qui date d'avant 2008. L'installation n'a pas demandé de mise à jour car il n'y en avait pas.
Il n'est pas impossible que la demande émane de cette installation "vieillote" car le message "nécessite Framework 2.0" vient d'apparaître aussi au moment où j'ai scanné un document vers l'ordinateur.

Avant de passer à l'installation du framework, j'attends encore l'une ou l'autre proposition.

Merci encore
Messages postés
4758
Date d'inscription
dimanche 12 juin 2011
Statut
Contributeur
Dernière intervention
2 juillet 2020
1 033
'lut
Pourquoi me demande-t-il d'installer la version 2.0 alors qu'au moins la version 4.1 est déjà d'application ?
Car Microsoft, les créateurs du .NET Framework, sont visiblement incapables de créer des versions rétro-compatibles. Un programme .NET 1, 2, 3 ou 4 ne marchera que sur sa version respective. Les différentes versions peuvent s'installer à coté.

le SP2 est-il de rigueur (je suppose que oui) mais surtout quel choix parmi les trois propositions ?
Le SP2 est de rigueur. Quant au ficher à choisir, si Windows est installé en 32 bits, alors
_x86.exe
, sinon
_x64.exe
.

faut-il se satisfaire de la version 2.0 ? C'est-à-dire : faut-il aussi installer la dernière version pour des programmes plus récents ou attendre qu'il me le demande ?
Au choix. J'éviterai d'installer tout d'un coup, dans le cas où tu n'aies jamais besoin de programmes demandant les autres versions.
Messages postés
45
Date d'inscription
mercredi 21 juillet 2010
Statut
Membre
Dernière intervention
14 avril 2020

Tout grand merci gravgun. Entretemps, je me suis rendu compte que c'était bien l'installation du CD et la mise en oeuvre de l'imprimante qui nécessite la version 2.
Merci à tous.
Messages postés
111
Date d'inscription
dimanche 3 juillet 2016
Statut
Membre
Dernière intervention
20 octobre 2016
30
As-tu téléchargé un Trojan ou pas. Télécharge ZHPCleaner et fais un scan