Importé le nom d'une feuille dans une formule depuis une cellule

Résolu/Fermé
Ben33170 - 10 juin 2016 à 00:28
Raymond PENTIER Messages postés 56714 Date d'inscription lundi 13 août 2007 Statut Contributeur Dernière intervention 6 octobre 2022 - 10 juin 2016 à 05:24
Bonjour,

Je vais essayer de m'exprimer clairement, je cherche à importer le nom d'une feuille dans une formule depuis une cellule, pour des stats à la semaine sur des commerciaux :

voici ma formule :
=NB.SI('S23'!A1:A100;"SL")+NB.SI('S24'!A1:A100;"SL")

S23 et S24 correspondent à des numéros de semaine.
J'aimerais que cette "valeur" qui correspond au nom des feuilles de calcul de chaque semaine, corresponde à une cellule de la feuille "Stats par commerciaux"

Ainsi je pourrais modifier directement les cellules "valeur de page" qui modifierais du coup chaque ligne de la feuille de stats..

Ex :
Je met en B1/C1/D1/E1 manuellement les valeurs S23/S24/S25/S26
Et dans la formule :
=NB.SI('CelluleB1'!A1:A100;"SL")+NB.SI('CelluleC1'!A1:A100;"SL")

Je cherche depuis 1h00 et ne trouve rien !

Quelqu'un pour m'aiguiller ?

Merci !

2 réponses

Raymond PENTIER Messages postés 56714 Date d'inscription lundi 13 août 2007 Statut Contributeur Dernière intervention 6 octobre 2022 17 184
10 juin 2016 à 00:51
Bonjour.

Essaie
=NB.SI(INDIRECT(B1&"!A1"&":A100");"SL")
+NB.SI(INDIRECT(C1&"!A1"&":A100");"SL")

0
Yes ça marche ! Merci beaucoup j'avais essayé avec indirect mais apparement j'avais pas bien fait les choses !

Merci pour ta réactivité c'est top !
0
Raymond PENTIER Messages postés 56714 Date d'inscription lundi 13 août 2007 Statut Contributeur Dernière intervention 6 octobre 2022 17 184
10 juin 2016 à 05:24
C'est vrai que ce n'est pas évident ! j'ai tatonné pas mal avant d'arriver enfin à l'écriture correcte de la formule ...
Mais je suis heureux que cela te donne satisfaction.

Et à la prochaine .
0