Plus d'accès à wp-admin

Fermé
Signaler
Messages postés
1723
Date d'inscription
vendredi 4 janvier 2008
Statut
Membre
Dernière intervention
4 décembre 2021
-
Messages postés
5840
Date d'inscription
mercredi 30 octobre 2013
Statut
Membre
Dernière intervention
17 mars 2021
-
Bonjour à tous et toutes,

la question a peut-être déjà été posée et si oui j'en suis désolée, j'ai cherché mais n'ai rien trouvé.

J'ai déménagé un site WordPress et depuis plus grand chose ne fonctionne.

Il est actif à l'adresse https://asinerie-de-kergall.com/ les menus fonctionnent mais les images ne sont pas visibles lors de la consultation des pages.

Je voudrais bien aller vérifier les liens etc, mais je n'ai pas d'accès à mon administration. Si j'essaye d'accéder au tableau de bord, j'obtiens ça :

https://www.dropbox.com/s/obllky5z82bzwq6/GandiWpAdmin.jpg?dl=0

Et aucun des liens ne fonctionne.

Je précise que ce site est hébergé chez Gandi, et que l'url redirige aussi vers un ancien site (moche). Est ce que le problème pourrait venir de là?

Normalement, chez Gandi, www.asinerie-de-kergall.com pointe vers l'ancien site, et asinerie-de-kergall non, mais quand je consulte la liste des redirections chez Gandi, les deux sont redirigées, non ?

https://www.dropbox.com/s/7oh9wt126b9ky0o/Gandi.jpg?dl=0

Je n'ose pas supprimer la redirection chez eux, parce que l'ancien site, même moche, a le mérite d'exister...

Je galère là-dessus depuis un certain temps, Gandi ne m'est pas d'une grande aide, Comment ça marche est mon dernier espoir, alors mille merci à toutes les personnes qui pourront me donner un coup de pouce !!!!!
(J'espère avoir fourni à peu près assez d'info, sinon posez moi toutes les questions qui vous passent par la tête...)

LatelyGeek


Pourquoi se compliquer la vie à faire simple, quand c'est si simple de faire compliqué?

1 réponse

Messages postés
5840
Date d'inscription
mercredi 30 octobre 2013
Statut
Membre
Dernière intervention
17 mars 2021
1 302
Bonjour

tu as oublié de modifier les urls dans ta base de donnée, du coup elles pointent vers l'ancienne adresse.
va sur ton hébergeur et cherche le gestionnaire de donnée généralement c'est phpmyadmin, connecte-toi à ta bdd, clique sur le nom de ta bdd dans le menu de gauche puis sur la table wp_options (ou xx_options si tu as changer le préfixe)

une fois la table ouverte

regarde si les deux premières lignes ayant respectivement home et siteurl dans la colonne option-name contiennt bien l'adresse de ton site dans la colonne options-values sinon double-clique sur l'adresse et modifie-la pour qu'elle corresponde a celle que tu utilises ( attention, ne mets pas de slash à la fin)


vérifie ensuite si ton site apparaît correctement et que tu peux te connecter a wp-admin, si oui tu peux fermer phpmyadmin
0
Messages postés
1723
Date d'inscription
vendredi 4 janvier 2008
Statut
Membre
Dernière intervention
4 décembre 2021
543
Bonjour, et merci de ta réponse ! C'est vrai que j'ai oublié de préciser toutes les manips' que j'ai déjà faites, mais je pensais que ça "tombait sous le sens" puisque je vois quand même mon site à cette adresse.
J'ai balayé ma base de données, partout - enfin sûrement pas partout puisque ça ne fonctionne pas complètement.

J'ai modifié wp-options, wp-posts aussi, d'une manière générale j'ai fait la recherche de l'ancienne adresse dans toutes les tables, j'ai modifié partout où je pouvais grâce aux requêtes SQL indiquées dans un site très bien fait (https://wpformation.com/deplacer-wordpress-nom-domaine/

Grâce à ces manips j'ai pu mettre le site en ligne à l'adresse souhaitée, mais ne vois pas les images et surtout comme dit plus haut, je n'accède pas au wp-admin.

Je suis désolée de ne pas l'avoir précisé dans mon premier post...
0
Messages postés
5840
Date d'inscription
mercredi 30 octobre 2013
Statut
Membre
Dernière intervention
17 mars 2021
1 302 >
Messages postés
1723
Date d'inscription
vendredi 4 janvier 2008
Statut
Membre
Dernière intervention
4 décembre 2021

tout ce que je vois dans ton code, c'est que certaines de tes url d' images pointent vers xxxx- url-de-test-ws , est ce que tu as mis ces images directement dans le code du thème ?
pour le wp-admin, est ce que tu as effacé le fichier .htaccess situé à la racine ?
0
Messages postés
1723
Date d'inscription
vendredi 4 janvier 2008
Statut
Membre
Dernière intervention
4 décembre 2021
543
Je vais de ce pas vérifier ce dont tu me parles, il me semblait pourtant avoir modifié toutes les redirections vers url-de-test... :(

Merci de ta réponse en tout cas !
0
Messages postés
1723
Date d'inscription
vendredi 4 janvier 2008
Statut
Membre
Dernière intervention
4 décembre 2021
543
Vérification faite avec FileZilla, on dirait bien que j'ai supprimé .htaccess.
0
Messages postés
1723
Date d'inscription
vendredi 4 janvier 2008
Statut
Membre
Dernière intervention
4 décembre 2021
543
Et quand j'inspecte mon "tableau de bord", je trouve plein d'erreurs de ce style :

Mixed Content: The page at 'https://5108542.admin.dc0.gpaas.net/vhosts/asinerie-de-kergall.com/htdocs/' was loaded over HTTPS, but requested an insecure script 'http://asinerie-de-kergall.com/wp-content/plugins/nextgen-gallery/products/…ti_nextgen/modules/nextgen_gallery_display/static/common.min.js?ver=2.1.20'. This request has been blocked; the content must be served over HTTPS.

Comment je fais pour passer de https à http ? D'où vient ce souci ?
0