Extraire lignes si 2 critères texte respectés [Résolu/Fermé]

Signaler
Messages postés
24
Date d'inscription
jeudi 23 juin 2011
Statut
Membre
Dernière intervention
24 mai 2016
-
Messages postés
25456
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
28 octobre 2020
-
Bonjour, je sais qu'il y a déjà eu des questions similaires, mais je n'arrive pas à faire ce que je veux.
Dans une base de donnée, je souhaiterais extraire dans une page excel externe les lignes contenant 2 critères "critère 1=le nom"(colonne c) et "critère 2=le produit vendu" (colonne F).

J'ai essayé avec la formule index mais ils me mettent que la fonction est incorrecte.

Comment faire ?
Merci d'avance

1 réponse

Messages postés
25456
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
28 octobre 2020
5 563
Bonjour
voyez si ce modèle qui utilise une colonne de codage peut répondre à votre question
https://www.cjoint.com/c/FEskW5JJ7pC
crdlmnt
Messages postés
24
Date d'inscription
jeudi 23 juin 2011
Statut
Membre
Dernière intervention
24 mai 2016

merci de votre réponse, mais à quel moment dois je rentrer mes critères de sélection ? Ile fomrule du type =SI(ET(A="pierre";B="lampe");LIGNE(1);"") Pour que la ligne entière soit extraaite. J'ai du mal à comprendre vos 2 formules ( leur utilité)

merci
Messages postés
25456
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
28 octobre 2020
5 563
ce n'est pas la formule que j'"ai placé en colonne F modèle, ce serait plutôt celle ci

=SI(ET(A2="";B2="");"";SI(ET(A2=$J$18;B2=$K$18);MAX($F$1:F1)+1;""))

Dans formule qui est tirée de F2 à F49 il s'agit de MAX($F$1:F1)+1 (et pas de ligne A1) qui incrémente son résultat de 1 chaque fois qu'elle trouve
(en fait elle rajoute 1 à la valeur maxi trouvée dans le champ au dessus de sa position toutes les fois que les conditions sont réunies)
__en A le code sélectionné en J18
__et en B le, code sélectionné en K18

vous verrez le résultat si vous modifier des valeurs, de J18 et K18

si problème et si c'est possible, mettez votre modèle (avec quelques explications) à disposition sur le site:
https://www.cjoint.com/
créez le lien et revenez le coller ici

à vous lire
crdlmnt
Messages postés
24
Date d'inscription
jeudi 23 juin 2011
Statut
Membre
Dernière intervention
24 mai 2016

J'ai réussi !
Merci beaucoup et bonne journée
Messages postés
25456
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
28 octobre 2020
5 563
Pas de quoi, je passe le sujet en résolu
Bonne route
cdrlmnt