Somme entre deux dates avec plusieurs critères [Résolu/Fermé]

Signaler
Messages postés
113
Date d'inscription
mardi 2 juin 2015
Statut
Membre
Dernière intervention
22 mai 2018
-
Messages postés
113
Date d'inscription
mardi 2 juin 2015
Statut
Membre
Dernière intervention
22 mai 2018
-
Bonjour,
J’aimerais calculer la différence d’une somme entre l’avant dernière saisie et la dernière saisie et un code, manuellement je sais le faire, mais je voudrais savoir si l'on peut le faire avec une formule et recopier cette formule vers le bas. Pour faciliter la compréhension je joins un fichier exemple.
Exemple : avant dernière saisie pour haricot vert (date 07/05/2016 et code 103)
Et dernière saisie haricot vert (date 02/12/2016 et code 103)
http://www.cjoint.com/data3/FEqq2sxdijc_essai-date.docx

6 réponses

Messages postés
25172
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
9 juillet 2020
5 352
Bonsoir
doit y avoir une petite erreur dans le dépôt de fichier
à vous lire
Messages postés
113
Date d'inscription
mardi 2 juin 2015
Statut
Membre
Dernière intervention
22 mai 2018

Re bonjour
je remet le fichier
http://www.cjoint.com/data3/FEqq2sxdijc_essai-date.docx
Messages postés
25172
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
9 juillet 2020
5 352
celui là vous pouvez le remettre encore et encore.., il s'agit d'un Word, copie conforme de votre message.. un brouillon sans doute?
mais ça ne pemettra pas d'avancer
Messages postés
113
Date d'inscription
mardi 2 juin 2015
Statut
Membre
Dernière intervention
22 mai 2018

Oups désolé je pose le bon fichier
http://www.cjoint.com/data3/FEqrly3Vypc_Exemple.xlsx
Messages postés
25172
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
9 juillet 2020
5 352
votre fichier en retour avec une proposition et quelques explications
https://www.cjoint.com/c/FEqrGm38PyC
Revenez si ça ne convient pas
crdlmnt
Messages postés
113
Date d'inscription
mardi 2 juin 2015
Statut
Membre
Dernière intervention
22 mai 2018

Bonjour,
Merci pour la formule qui correspond parfaitement à mes besoins. Mais j’ai quand même un souci avec mon fichier final, en effet dans la colonne où j’ai recopié la formule toutes les cellules ne sont pas remplies. Je me permets de joindre le fichier pour vous permettre si vous avez le temps de le regarder, la colonne en question se trouve en Z.
Merci de votre patience
https://www.cjoint.com/doc/16_05/FErrle8i5dc_Essai.xlsm
Messages postés
25172
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
9 juillet 2020
5 352
Bonsoir
je ne veux pas tout pointer, mais je pense que vous pourrez vous, habitué au fichier, vérifier rapidement
les cellules vides sont celles ou le code en H apparaît pour la 1° fois, il n'est donc pas possible de faire la différence avec la ligne précédente.

revenez si ça n'est pas le cas, en signalant les cellules à problème

Par ailleurs si vous voulez une information texte au lieu d'une cellule vide dans le cas cité, il suffit d'insérer le texte voulu entre les guillemets à la fin de la formule

crdlmnt

Ps en complément après contrôle, il semble que votre formule en Z2 est mal calée voyez ci dessous la position des $ dans l'adresse $A$1:A1 en gras

=SIERREUR(INDEX($V$2:V2;EQUIV(H2&MAX(SI($H1:H$1=H2;$A$1:A1));$H$2:H2&$A$2:A2;0))-V2;"")

voyez ici après correction
https://www.cjoint.com/c/FErrRjQWB4C

les codes apparaissent en jaune pour leur 1° apparition. (donc avec Z vide)
Messages postés
113
Date d'inscription
mardi 2 juin 2015
Statut
Membre
Dernière intervention
22 mai 2018

Re bonjour,
J’ai masqué les colonnes pas nécessaires et trié la colonne H pour mieux voire le problème, dans la cellule Z12 il manque le résultat. Je ne comprends pas, parfois il manque le résultat puis la cellule d’après cela remarche.
https://www.cjoint.com/doc/16_05/FErswj2hRac_Essai.xlsm
Messages postés
25172
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
9 juillet 2020
5 352
vous avez du zapper la fin de mon message, mais c'est normal car je l'ai rajouté plus tard en ps
voyez le fichier joint en fin de message avec la correction de formule proposée et dites moi ce qui ,ne va pas
crdlmnt
Messages postés
113
Date d'inscription
mardi 2 juin 2015
Statut
Membre
Dernière intervention
22 mai 2018
>
Messages postés
25172
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
9 juillet 2020

Bonsoir,
Avec vos modifications, tous les calculs se font parfaitement. Mais (encore un mais) j’ai fait une erreur, la formule calcule V14-V8 et moi j’aimerais V8-V14 serait-il possible de modifier la formule en conséquence. Comme ça, je pourrais comparer les deux formules et essayer de comprendre.
Merci de votre compréhension et de votre patience.
https://www.cjoint.com/c/FEsq1MP4qzc
Messages postés
25172
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
9 juillet 2020
5 352
si j'ai bien compris, il devrait suffire d'inverser le signe du résultat
avec ce genre de technique

=SIERREUR((INDEX($V$2:V2;EQUIV(H2&MAX(SI($H1:H$1=H2;$A$1:A1));$H$2:H2&$A$2:A2;0))-V2)*-1;"")

toujours en matricielle

attention à la bonne position des parenthèses rajoutées pour englober depuis derrière SIERREUR jusqu'après -V2)

crdlmnt
Messages postés
113
Date d'inscription
mardi 2 juin 2015
Statut
Membre
Dernière intervention
22 mai 2018

Bonsoir,
Merci pour votre réponse rapide tout marche comme je le souhaite, je vous remercie encore pour vos réponses et surtout votre patience.
Encore merci et peut être à bientôt sur le forum