Somme entre deux dates avec plusieurs critères

Résolu/Fermé
Bourrique66
Messages postés
140
Date d'inscription
mardi 2 juin 2015
Statut
Membre
Dernière intervention
11 février 2022
- 16 mai 2016 à 18:58
Bourrique66
Messages postés
140
Date d'inscription
mardi 2 juin 2015
Statut
Membre
Dernière intervention
11 février 2022
- 18 mai 2016 à 20:07
Bonjour,
J’aimerais calculer la différence d’une somme entre l’avant dernière saisie et la dernière saisie et un code, manuellement je sais le faire, mais je voudrais savoir si l'on peut le faire avec une formule et recopier cette formule vers le bas. Pour faciliter la compréhension je joins un fichier exemple.
Exemple : avant dernière saisie pour haricot vert (date 07/05/2016 et code 103)
Et dernière saisie haricot vert (date 02/12/2016 et code 103)
http://www.cjoint.com/data3/FEqq2sxdijc_essai-date.docx

6 réponses

Vaucluse
Messages postés
26495
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 avril 2022
6 254
16 mai 2016 à 19:02
Bonsoir
doit y avoir une petite erreur dans le dépôt de fichier
à vous lire
0
Bourrique66
Messages postés
140
Date d'inscription
mardi 2 juin 2015
Statut
Membre
Dernière intervention
11 février 2022
2
16 mai 2016 à 19:06
Re bonjour
je remet le fichier
http://www.cjoint.com/data3/FEqq2sxdijc_essai-date.docx
0
Vaucluse
Messages postés
26495
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 avril 2022
6 254
16 mai 2016 à 19:10
celui là vous pouvez le remettre encore et encore.., il s'agit d'un Word, copie conforme de votre message.. un brouillon sans doute?
mais ça ne pemettra pas d'avancer
0
Bourrique66
Messages postés
140
Date d'inscription
mardi 2 juin 2015
Statut
Membre
Dernière intervention
11 février 2022
2
16 mai 2016 à 19:13
Oups désolé je pose le bon fichier
http://www.cjoint.com/data3/FEqrly3Vypc_Exemple.xlsx
0
Vaucluse
Messages postés
26495
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 avril 2022
6 254
16 mai 2016 à 19:33
votre fichier en retour avec une proposition et quelques explications
https://www.cjoint.com/c/FEqrGm38PyC
Revenez si ça ne convient pas
crdlmnt
0
Bourrique66
Messages postés
140
Date d'inscription
mardi 2 juin 2015
Statut
Membre
Dernière intervention
11 février 2022
2
17 mai 2016 à 19:12
Bonjour,
Merci pour la formule qui correspond parfaitement à mes besoins. Mais j’ai quand même un souci avec mon fichier final, en effet dans la colonne où j’ai recopié la formule toutes les cellules ne sont pas remplies. Je me permets de joindre le fichier pour vous permettre si vous avez le temps de le regarder, la colonne en question se trouve en Z.
Merci de votre patience
https://www.cjoint.com/doc/16_05/FErrle8i5dc_Essai.xlsm
0
Vaucluse
Messages postés
26495
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 avril 2022
6 254
Modifié par Vaucluse le 17/05/2016 à 19:44
Bonsoir
je ne veux pas tout pointer, mais je pense que vous pourrez vous, habitué au fichier, vérifier rapidement
les cellules vides sont celles ou le code en H apparaît pour la 1° fois, il n'est donc pas possible de faire la différence avec la ligne précédente.

revenez si ça n'est pas le cas, en signalant les cellules à problème

Par ailleurs si vous voulez une information texte au lieu d'une cellule vide dans le cas cité, il suffit d'insérer le texte voulu entre les guillemets à la fin de la formule

crdlmnt

Ps en complément après contrôle, il semble que votre formule en Z2 est mal calée voyez ci dessous la position des $ dans l'adresse $A$1:A1 en gras

=SIERREUR(INDEX($V$2:V2;EQUIV(H2&MAX(SI($H1:H$1=H2;$A$1:A1));$H$2:H2&$A$2:A2;0))-V2;"")

voyez ici après correction
https://www.cjoint.com/c/FErrRjQWB4C

les codes apparaissent en jaune pour leur 1° apparition. (donc avec Z vide)
0

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
Bourrique66
Messages postés
140
Date d'inscription
mardi 2 juin 2015
Statut
Membre
Dernière intervention
11 février 2022
2
17 mai 2016 à 20:22
Re bonjour,
J’ai masqué les colonnes pas nécessaires et trié la colonne H pour mieux voire le problème, dans la cellule Z12 il manque le résultat. Je ne comprends pas, parfois il manque le résultat puis la cellule d’après cela remarche.
https://www.cjoint.com/doc/16_05/FErswj2hRac_Essai.xlsm
0
Vaucluse
Messages postés
26495
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 avril 2022
6 254
17 mai 2016 à 20:42
vous avez du zapper la fin de mon message, mais c'est normal car je l'ai rajouté plus tard en ps
voyez le fichier joint en fin de message avec la correction de formule proposée et dites moi ce qui ,ne va pas
crdlmnt
0
Bourrique66
Messages postés
140
Date d'inscription
mardi 2 juin 2015
Statut
Membre
Dernière intervention
11 février 2022
2 > Vaucluse
Messages postés
26495
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 avril 2022

18 mai 2016 à 18:54
Bonsoir,
Avec vos modifications, tous les calculs se font parfaitement. Mais (encore un mais) j’ai fait une erreur, la formule calcule V14-V8 et moi j’aimerais V8-V14 serait-il possible de modifier la formule en conséquence. Comme ça, je pourrais comparer les deux formules et essayer de comprendre.
Merci de votre compréhension et de votre patience.
https://www.cjoint.com/c/FEsq1MP4qzc
0
Vaucluse
Messages postés
26495
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 avril 2022
6 254
18 mai 2016 à 19:07
si j'ai bien compris, il devrait suffire d'inverser le signe du résultat
avec ce genre de technique

=SIERREUR((INDEX($V$2:V2;EQUIV(H2&MAX(SI($H1:H$1=H2;$A$1:A1));$H$2:H2&$A$2:A2;0))-V2)*-1;"")

toujours en matricielle

attention à la bonne position des parenthèses rajoutées pour englober depuis derrière SIERREUR jusqu'après -V2)

crdlmnt
0
Bourrique66
Messages postés
140
Date d'inscription
mardi 2 juin 2015
Statut
Membre
Dernière intervention
11 février 2022
2
18 mai 2016 à 20:07
Bonsoir,
Merci pour votre réponse rapide tout marche comme je le souhaite, je vous remercie encore pour vos réponses et surtout votre patience.
Encore merci et peut être à bientôt sur le forum
0