Conditions à appliquer sur un calcul sous OpenOffice Calc [Résolu/Fermé]

Signaler
-
 Luigi62 -
Bonjour à tous,

Surement simple aux yeux de certains, mais pour moi....

Ma base en cellule B15 doit afficher le calcul suivant : =SOMME(2+B11+B13-B14), ça j'y arrive ! ;)
Maintenant ce résultat doit être soumis à certaines conditions suivantes:
1- Si la SOMME est < à 0, alors B15 doit afficher 0
2- Ou Si B14 est vide, alors B15 doit aussi afficher 0
Et là, avec ces 2 conditions, je n'y arrive plus, ou que partiellement.

Une bonne "tête" bien faite pourrait-elle me trouver la bonne formule ?

Merci d'avance

1 réponse

Messages postés
50738
Date d'inscription
mardi 8 janvier 2008
Statut
Modérateur
Dernière intervention
27 janvier 2021
6 722
Bonjour,

Il faut imbriquer tes conditions...
Bonjour Chris94,
J'avais bien tenté d'imbriquer, mais rien à faire, je dois faire une erreur quelque part.
Une formule valide m'aiderait beaucoup.
Messages postés
2277
Date d'inscription
vendredi 25 juillet 2014
Statut
Membre
Dernière intervention
25 janvier 2021
984
Bonsoir
=SI(OU(2+B11+B13-B14<0;B14="");0;2+B11+B13-B14)
>
Messages postés
2277
Date d'inscription
vendredi 25 juillet 2014
Statut
Membre
Dernière intervention
25 janvier 2021

Yessss ! Ca fonctionne et j'ai vu où était mon erreur.
Merci mille fois yclik et bonne soirée !