Numéro

Fermé
SmartAndClever
Messages postés
14
Date d'inscription
mardi 7 juillet 2015
Statut
Membre
Dernière intervention
14 avril 2016
- 19 mars 2016 à 00:38
eriiic
Messages postés
24446
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
17 septembre 2022
- 19 mars 2016 à 09:39
bonjour à tous.
Regardez ce petit exemple.
il y a dans cet exercice des numéros de téléphones suivants:
081 26 27 281:
082 21 93 199:

085 180 8065:
084 125 3308;
j'aimerai trouver en Excel une solution qui pourra me donner le nombre des personnes qui utilisent le reseau Vodacom et celles qui utilisent le reseau Orange

les prefixes 081 et 082 sont pour vodacom et 085 et 084 sont pour orange. Comment trouver la réponse je vous prie.

3 réponses

Raymond PENTIER
Messages postés
56673
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
25 septembre 2022
17 183
19 mars 2016 à 04:26
Bonjour.

Essaie d'utiliser la fonction GAUCHE pour extraire les 3 premiers caractères de chaque N° et les compter ...
0
Vaucluse
Messages postés
26495
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 avril 2022
6 272
19 mars 2016 à 07:05
Bonjour

deux options possibles selon que vos numéros sont entrés en texte ou en format téléphone

1° cas le préfixe est un texte 0xx
2° cas le préfixe est une valeur num xx pour laquelle Excel rajoute le 0 dans le format

pour un champ de A1 à A100
1° cas
=SOMMEPROD((GAUCHE((A1:A100;3)="081")*1)+SOMMEPROD((GAUCHE(A1:A100;3)="082")*1))

2° cas
=SOMMEPROD((GAUCHE(A1;2)*1=81)*1)+SOMMEPROD((GAUCHE(A1;2)*1=82)*1)

à vous de voir dans quel format sont vos N° _voir s'il s'affiche dans la barre de formule avec le 0 (texte) ou sans (num)

crdlmnt
0
eriiic
Messages postés
24446
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
17 septembre 2022
7 127
19 mars 2016 à 09:39
Bonjour,

Je dirais qu'avec la portabilité du n° tu ne peux pas.
Sinon :
=NB.SI(A:A;"081*")+NB.SI(A:A;"082*")
eric
0