Fonction si avec 6 conditions

[Fermé]
Signaler
-
Messages postés
26122
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
30 juillet 2021
-
Bonjour,
Je voudrais créer une formule où, dans une cellule, j'ai S1;S2;S3;S4;S5;SN, je souhaiterais que dans une autre cellule, si j'ai S1 dans la première, dans la deuxième, j'ai <=10, si S2 dans la premiere alors <= 30 dans la deuxième et ainsi de suite, si vous avez une solution, je suis preneur...

Un grand merci d'avance


A voir également:

2 réponses

Messages postés
2516
Date d'inscription
vendredi 25 juillet 2014
Statut
Membre
Dernière intervention
29 juillet 2021
1 156
Bonjour
Il faudrait peut être un tableau de correspondance et ensuite utiliser la fonction RECHERCHEV
merci beaucoup pour l'info je vais tenter les deux manières, par contre je ne connais pas trop le fonctionnement de la fonction recherchev, je dois faire un tableau à coté et le reporter dans le principal c'est bien ca?

très cordialement
Messages postés
26122
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
30 juillet 2021
5 998
Bonjour
REHERCHEV est une solution, ou avec la condition SI:

=SI(cell1="S1";"<=10";SI(Cell2="S2";"<=30";SI(.....))))))
fermez la formule par autant de parenthèses que de SI

crdlmnt

La qualité de la réponse dépend surtout de la clarté de la question, merci!
merci beaucoup je vais essayer ca, par contre, je viens de voir je me suis mal exprimé, les S1;S2......S5 sont dans la même cellule, dans un menu déroulant, du coup votre formule fonctionne tout de même?

très cordialement
Messages postés
26122
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
30 juillet 2021
5 998 > benjaminb
La formule fonctionne pour une seule cellule selon le code qui apparaît dans la cellule de référence.
Il suffit de répéter l'adresse de la même cellule à chaque item de condition
essayez, c'est ce qu'il y a de mieux pour voir

crdlmnt