Somme chiffres positifs double condtion [Résolu/Fermé]

Signaler
Messages postés
3
Date d'inscription
lundi 27 août 2012
Statut
Membre
Dernière intervention
16 mars 2016
-
Messages postés
3
Date d'inscription
lundi 27 août 2012
Statut
Membre
Dernière intervention
16 mars 2016
-
Bonjour,

J'ai parcouru (un peu) le forum, et n'ai pas réussi à trouver la réponse à mon problème.
Je souhaite réussir à calculer la somme de l'ensemble des chiffres positifs (ou négatifs) d'une plage si et seulement si deux conditions sont remplies.
Je m'explique:
- plage A1:A10, les cellules ont trois valeurs possibles: a, b, c
- plage B1:B10, les cellules ont trois valeurs possibles: d, e, f
- plage C1:C10, les cellules calculent une somme avec des nombres positifs, négatifs ou nuls
Ce que je souhaite afficher:
- en D1: la somme des nombres positifs de C1:C10, seulement si ceux ci ont pour critère la valeur "a" dans la plage A1:A10, et la valeur "e" dans la plage B1:B10
- en E1: la somme des nombres négatifs de C1:C10, seulement si ceux ci ont pour critère la valeur "a" dans la plage A1:A10, et la valeur "e" dans la plage B1:B10
- en F1: la somme des nombres positifs de C1:C10, seulement si ceux ci ont pour critère la valeur "c" dans la plage A1:A10, et la valeur "d" dans la plage B1:B10
etc...
J'ai essayé avec SOMME.SI.ENS, mais je ne peux pas faire le filtre sur le fait que je ne veux que les nombre positifs dans ma somme.
J'ai essayé avec SOMME.SI, mais je n'arrive pas à inclure mes deux conditions préalables...

Si quelqu'un a compris mon exemple, et une idée de la bonne formule (je ne préfère pas passé par du VBA), je suis preneur :)

Merci par avance de votre aide!!

1 réponse

Messages postés
5477
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
26 mai 2020
441
Bonjour kikititis

- en D1: la somme des nombres positifs de C1:C10, seulement si ceux ci ont pour critère la valeur "a" dans la plage A1:A10, et la valeur "e" dans la plage B1:B10
=SOMME.SI.ENS($C$1:$C$10;$A$1:$A$10;"a";$B$1:$B$10;"e";$C$1:$C$10;">0")

- en E1: la somme des nombres négatifs de C1:C10, seulement si ceux ci ont pour critère la valeur "a" dans la plage A1:A10, et la valeur "e" dans la plage B1:B10
=SOMME.SI.ENS($C$1:$C$10;$A$1:$A$10;"a";$B$1:$B$10;"e";$C$1:$C$10;"<0")

- en F1: la somme des nombres positifs de C1:C10, seulement si ceux ci ont pour critère la valeur "c" dans la plage A1:A10, et la valeur "d" dans la plage B1:B10
=SOMME.SI.ENS($C$1:$C$10;$A$1:$A$10;"c";$B$1:$B$10;"d";C1:C10;">0")
2
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 86366 internautes nous ont dit merci ce mois-ci

Messages postés
3
Date d'inscription
lundi 27 août 2012
Statut
Membre
Dernière intervention
16 mars 2016

Merci Philou, je n'avais pas compris qu'il fallait que je remette la plage de somme comme critère à la fin :)
Une petite dernière question: pourquoi bloqué les cellules de plage de somme ou de critère avec des "$"?
Messages postés
5477
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
26 mai 2020
441 >
Messages postés
3
Date d'inscription
lundi 27 août 2012
Statut
Membre
Dernière intervention
16 mars 2016

Ce n'est pas une obligation dans votre cas les formules étant fixées en ligne 1
Messages postés
3
Date d'inscription
lundi 27 août 2012
Statut
Membre
Dernière intervention
16 mars 2016
>
Messages postés
5477
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
26 mai 2020

Ok, merci encore :)