Recherche Formule

Résolu/Fermé
AS016 Messages postés 4 Date d'inscription samedi 12 mars 2016 Statut Membre Dernière intervention 12 mars 2016 - 12 mars 2016 à 21:00
AS016 Messages postés 4 Date d'inscription samedi 12 mars 2016 Statut Membre Dernière intervention 12 mars 2016 - 12 mars 2016 à 23:03
Bonsoir tout le monde,

je souhaite avoir un petit coup de pouce en cherchant une formule sur excel, qui me permettra de chercher une valeur donnée dans une colonne puis simultanément réaliser une opération numérique des valeurs qui la précède,

je vous remercie de vos aides précieuses

CRDLT

5 réponses

DjiDji59430 Messages postés 3729 Date d'inscription samedi 19 avril 2008 Statut Membre Dernière intervention 29 janvier 2023 569
12 mars 2016 à 21:20
Bonjour,

Quand on joint un fichier-test, (avec TOUTES les explications ou les résultats souhaités) ou mieux, si c'est possible, le fichier concerné, c'est plus commode pour les intervenants. Et tu as plus de chances que quelqu'un s’intéresse à ton problème

1) Tu vas dans https://www.cjoint.com/
2) Tu cliques sur [Parcourir] pour sélectionner ton fichier
3) Tu descends en bas de la page pour cliquer sur [Créer le lien Cjoint]
4) Au bout de quelques secondes s'affiche le lien en bleu souligné ; tu le sélectionnes et tu fais "Copier"
5) Tu reviens dans la discussion, et, dans ton message de réponse, tu fais : "Coller".

Cordialement.
1
gbinforme Messages postés 14939 Date d'inscription lundi 18 octobre 2004 Statut Contributeur Dernière intervention 24 juin 2020 4 647
12 mars 2016 à 21:28
Bonjour,

Ta question n'est pas très documentée, mais comme tu veux utiliser les cellules qui précédent, tu devrais regarder avec DECALER et EQUIV pour la recherche, par exemple :
=SOMME(DECALER($A$1;EQUIV("xx";E:E;0)-1;;1;4))
1
AS016 Messages postés 4 Date d'inscription samedi 12 mars 2016 Statut Membre Dernière intervention 12 mars 2016
12 mars 2016 à 21:57
je m'excuse pour cette question un peu parachutée, voici un document joint qui explique mieux ma question, j'ai beau réaliser des formules beaucoup plus complexe je ne sais pas prk je bug sur celle-ci https://www.cjoint.com/c/FCmu1FMiERv
0
gbinforme Messages postés 14939 Date d'inscription lundi 18 octobre 2004 Statut Contributeur Dernière intervention 24 juin 2020 4 647
12 mars 2016 à 22:38
Bonjour,

Je ne suis pas un familier de ce genre de calcul mais regardes si cette formule ne te donnes pas le résultat attendu :
=11/RACINE(SOMMEPROD(DECALER($C$1;1;0;EQUIV($J$1;A:A;0)-2;1)))
1
AS016 Messages postés 4 Date d'inscription samedi 12 mars 2016 Statut Membre Dernière intervention 12 mars 2016
12 mars 2016 à 22:00
voici un document joint du sujet, https://www.cjoint.com/c/FCmu1FMiERv
0

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
AS016 Messages postés 4 Date d'inscription samedi 12 mars 2016 Statut Membre Dernière intervention 12 mars 2016
12 mars 2016 à 23:03
=(PRODUIT(SI(A2:A30<J1;C2:C30;1)))^(1/(NB.SI(A2:A30;"<="&J1))) et on valide la formule avec Ctrl + Maj + Entré ... gbinforme Merci pour ton soutien je te revaudrais ça si jamais t'aurais besoin d'aide un jour (afif.saidi@hotmail.fr)
bonne soirée
0