Vba Remplir une cellule en fonction d'une autre

[Résolu/Fermé]
Signaler
Messages postés
348
Date d'inscription
mardi 19 octobre 2010
Statut
Membre
Dernière intervention
15 avril 2021
-
Messages postés
348
Date d'inscription
mardi 19 octobre 2010
Statut
Membre
Dernière intervention
15 avril 2021
-
Bonjour,

Voici mon problème j'ai un tableau de données,
ces données sont réparties sur 7 Niveaux.

Je veux compléter ma colonne AS en fonction du niveau,

c'est à dire si la colonne AU = 1 alors la valeur de AS = E
si la colonne AU = 2 alors la valeur de AS = F ....

Auriez vous un code sur lequel je puisse m'appuyer ?

Cdt
A voir également:

1 réponse

Messages postés
1412
Date d'inscription
mardi 21 octobre 2014
Statut
Membre
Dernière intervention
9 mars 2021
154
Bonjour Charlyjack, bonjour le forum,

Pourquoi un code ? je te propose la formule suivante à placer en AS1 et a tirer vers le bas :

=SI(AU1=1;"E";SI(AU1=2;"F";""))


Elle signifie : si AU1 est égale à 1, alors AS1 sera égale à "E". Si AU1 est égale à 2, alors AS1 sera égale à "F". Si AU1 est vide alors AS1 sera vide.
Messages postés
348
Date d'inscription
mardi 19 octobre 2010
Statut
Membre
Dernière intervention
15 avril 2021
1
Bonjour,

je pense que je me suis mal exprimer,
je veux récupérer la valeur de la colonne E sur la même ligne.

si AU16 = 1 alors je récupére le contenu de la cellule E16
si AU16= 2 alors je récupère le contenu de la cellule F16 ....

Désolé pour cette mauvaise formulation et merci de cette proposition
Messages postés
1412
Date d'inscription
mardi 21 octobre 2014
Statut
Membre
Dernière intervention
9 mars 2021
154
Re,

Alors essaie comme ça :

=SI(AU1=1;E1;SI(AU1=2;F1;""))


toujours à placer dans AS1 et à tirer vers le bas
Messages postés
348
Date d'inscription
mardi 19 octobre 2010
Statut
Membre
Dernière intervention
15 avril 2021
1 >
Messages postés
1412
Date d'inscription
mardi 21 octobre 2014
Statut
Membre
Dernière intervention
9 mars 2021

Bonjour et merci,

j ai un peu de mal avec les formules à rallonge mais ça fonctionne très bien

Bonne journée à toi Thautheme