Copie d'une cellule toutes les x lignes [Résolu/Fermé]

Signaler
-
Messages postés
575
Date d'inscription
vendredi 11 juillet 2014
Statut
Membre
Dernière intervention
30 mars 2016
-
Bonjour, je possède une feuille excel une colonne de 5200 données groupées (c'est à dire que la 1ère est dans la cellule A1 et la dernière dans la cellulle A5200). J'aimerais copier ces données sur une autre feuille mais je voudrais qu'il y ait une donnée toutes les 253 lignes. Comment faire pour ne pas faire ce travail donnée par donnée. Existe-t-il par exemple une option de collage "coller toutes les 253 lignes" ?

Merci d'avance

SB

1 réponse

Messages postés
575
Date d'inscription
vendredi 11 juillet 2014
Statut
Membre
Dernière intervention
30 mars 2016
19
Bonjour,

Vous pouvez dans une colonne juxtaposée calculer les lignes pour lesquelles il faudra copier la valeur, ensuite vous filtrez dessus et copier l'ensemble des lignes concernées.

La formule suivante à mettre en B1 puis à étirer affichera "ok" pour les lignes 1, 254, 507, 760, ... (toutes les 253 lignes en commençant par la ligne 1) :

=SI(MOD(LIGNE(A1)-1;9)=0;"ok";"")
Messages postés
575
Date d'inscription
vendredi 11 juillet 2014
Statut
Membre
Dernière intervention
30 mars 2016
19
Alt+F11, en haut à gauche sélectionner la feuille sur laquelle sont vos formules à étirer, puis coller ce code pour étirer la formule qui est en E1 jusqu'en E1310400 :
Sub test()
Range("E1").AutoFill Destination:=Range("E1:E1310400"), Type:=xlFillDefault
Range("E1:E1310400").Value = Range("A1:A1000").Value 'colle en valeurs pour éviter le recalcul trop long
End Sub

Ensuite, en gardant votre clic dans le texte collé (code vba), vous lancer la macro (flèche verte dans la barre d'action : "Exécuter Sub F5"

Attendre que ça traite toutes les lignes et voilà :-), attention ! par de CtrlZ possible, donc faites sur une copie au cas où ;)
En fait j'ai toujours un problème, j'ai beau filtrer, mon copier-coller ne copie pas que les lignes filtrées mais aussi les autres.
Messages postés
575
Date d'inscription
vendredi 11 juillet 2014
Statut
Membre
Dernière intervention
30 mars 2016
19
Vous vous y prenez mal sur la manip, il faut bien filtrer (n° de ligne en bleu sur la gauche), puis copier les cellules qui vous intéressent, et enfin coller dans une autre feuille

Nota: quelle version d'excel avez-vous?
Ok je vais essayer puis reviens vers vous. Je possède Excel 2016
Messages postés
575
Date d'inscription
vendredi 11 juillet 2014
Statut
Membre
Dernière intervention
30 mars 2016
19