Conversion cellule texte en heure

[Fermé]
Signaler
-
Messages postés
54766
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
1 octobre 2021
-
Bonjour,

J'ai cette cellule 13 736:06 en format texte que j'arrive pas à convertir en heure pour faire mes calculs. j'ai essayé =SI(B4="";"";CNUM(SUBSTITUE(B4;" ";""))) et bien d'autres, ça ne fonctionne pas. Quelqu'un pourrait m'aider SVP ça serait vraiment apprécié. Un grand merci !!

1 réponse

Messages postés
54766
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
1 octobre 2021
16 648
Et avec ce texte bizarre, quelle heure voudrais-tu obtenir ?
Messages postés
54766
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
1 octobre 2021
16 648 > Kalol
Il s'agit donc bien d'une durée de treize mille sept cent trente six heures et six minutes ; c'est-à-dire 1 an, 2 trimestres, 24 jours et 6 minutes ?
Quel type de mesure peut bien conduire à un tel résultat ? et avec une telle précision ? de l'astronautique, peut-être ?
>
Messages postés
54766
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
1 octobre 2021

Oui effectivement treize mille sept cent trente six heures et six minutes. En fait, c'est le nombre d'heures pour un groupe d'employé (574) pour une période donnée.
Messages postés
54766
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
1 octobre 2021
16 648
En A1 j'ai le texte "13 736:06"
En A2 la formule =SUBSTITUE(A1;" ";"") donne le texte "13736:06"
En A3 la formule =GAUCHE(A2;NBCAR(A2)-3) donne le texte "13736"
En A4 la formule =CNUM(A3) donne le nombre 13736
En A5 la formule =DROITE(A2;2) donne le texte "06"
En A6 la formule =CNUM(A5) donne le nombre 6
En A7 la formule =A4/24 donne le nombre 572,33333
En A8 la formule =A6/60/24 donne le nombre 0,004167
En A9 la formule =A7+A8 donne le nombre 572,3375
Avec la cellule A9 au format personnalisé [h]:mm la durée 13736:06 s'affiche !

Bien sûr, on peut aussi directement écrire une formule unique à partir de A1 :
=CNUM(GAUCHE(SUBSTITUE(A1;" ";"");NBCAR(SUBSTITUE(A1;" ";""))-3))/24
+ CNUM(DROITE(SUBSTITUE(A1;" ";"");2))/60/24
>
Messages postés
54766
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
1 octobre 2021

Un grand merci Raymond tu viens de me sauver la vie !!!
Messages postés
54766
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
1 octobre 2021
16 648 > Kalol
Heureux de t'avoir dépanné ...