Formule de calcul avec cellule de couleur

[Résolu/Fermé]
Signaler
Messages postés
1
Date d'inscription
lundi 15 février 2016
Statut
Membre
Dernière intervention
15 février 2016
-
Messages postés
54894
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
27 octobre 2021
-
Bonjour,
Je dois calculer le nombre de jour de présence des personnes sur un planning sur excel selon dans le service qu'il travail. Avant tous le monde travaillé dans le même service donc ma formule de calcul était :
=NB.SI(B6:BA6;"=1")+NB.SI(B6:BA6;"=0,5")/2+NB.SI(B6:BA6;"=0,5a")/2+NB.SI(B6:BA6;"=0,5aef")/2
(pour info 1 c'est pour une journée complète de travail 0.5 une demi journée 0.5a pour une demi journée d'absence et 0.5aef une demi journée d'absence qualifié)
maintenant les gens peuvent travaillé dans le mois sur différent service et j'ai besoin de savoir combien de temps de travail le gens on fait sur chaque service. Donc pour commencé j'ai mis les jours de différente couleur selon le service dans lesquels il travail mais je n'arrive pas à faire mon total par service.
Quelqu'un peux m'aider s'il vous plait?
Anne

2 réponses

Messages postés
13127
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
25 octobre 2021
2 273
Bonjour

Tu ne peux pas faire un total par couleurs sauf avec une macro et encore il faut que ce soit bien toujours la même couleur choisie !

Plus simplement tu devrais entrer dans les cellules du planning un code indiquant le service et la durée d'absence, par ex
S1-1, S1-0,5, S1_0,5a, S1_0,5aef
S2-1, S2-0,5, S2_0,5a, S2_0,5aef

Ta formule pour compter le total pour le service 1 devient alors :
=NB.SI(B6:BA6;"S1-1")+NB.SI(B6:BA6;"S1_0,5")/2..... etc

Et par différentes mises en formes conditionnelle tu peux faire colorer tes cellules du planning de couleurs différentes selon les services (cellules contenant le texte S1, cellules contenant le texte S2 ...)

Cdlmnt
Via
Messages postés
54894
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
27 octobre 2021
16 802
Question déjà posée 3 minutes avant !
http://www.commentcamarche.net/forum/affich-33168901-formule-avec-une-condition-de-couleur
CCM déteste les doublons, même si on s'inscrit comme membre entre les deux envois !