Problème avec la fonction recherchev

Fermé
zatox - 11 févr. 2016 à 17:44
zatox
Messages postés
641
Date d'inscription
samedi 17 février 2007
Statut
Membre
Dernière intervention
26 juin 2020
- 12 févr. 2016 à 18:06
Bonjour, la fonction recherchev marche très bien quand la cellule recherchée contient du texte, ce texte s'affiche bien dans la cellule contenant la formule recherchev mais ça ne marche pas quand la cellule recherchée contient un nombre !! est-ce que dans ce cas il faut faire quelque chose de plus ?
Je vous remercie pour vos réponses.



6 réponses

diablo13800
Messages postés
2790
Date d'inscription
jeudi 2 juillet 2015
Statut
Membre
Dernière intervention
17 mai 2022
1 775
11 févr. 2016 à 17:50
Bonjour,

Combien de paramètres vous avez a votre formule RechercheV?
Si vous en avait que 3 , rajoute ";Faux)" a la fin , ça évite les recherche approximative et peut résoudre votre problème.
Ou alors envoyez moi votre fonction

Cordialement
0
zatox
Messages postés
641
Date d'inscription
samedi 17 février 2007
Statut
Membre
Dernière intervention
26 juin 2020
64
11 févr. 2016 à 18:08
Bonjour et merci pour votre réponse, voici ma formule recherchev:

=RECHERCHEV("FS01";'C.A.DAV_01'.A2:P1001;9;0)

J'ai donc 4 paramètres, le dernier qui est l'ordre de tri est à zéro.

Le critère de recherche est FS01, la matrice se trouve dans une autre feuille ( C.A.DAV_01 de A2 à P1001) l'indice est 9 c'est à dire la neuvième colonne.

Si je donne par exemple la colonne 3, 4, 5, 6, ou 7 la cellule correspondante contient du texte et là ça marche, mais pour la 9 c'est un nombre et là la fonction ne m'affiche pas le contenu mais la cellule reste reste à blanc.

J'ai essayé en mettant "FAUX" à la place de 0 comme quatrième paramètre mais ça ne marche pas non plus.

Encore merci pour vos réponses.
0
diablo13800
Messages postés
2790
Date d'inscription
jeudi 2 juillet 2015
Statut
Membre
Dernière intervention
17 mai 2022
1 775
12 févr. 2016 à 09:13
Bonjour,

Donc si le chiffre est trouvé vous voulez affiché le contenu de la 9ieme colonne C'est donc ça?
Pouvez-vous (Si aucune donnée confidentiel) envoyé votre tableau Via ce site:
https://www.cjoint.com/

et collé le lien ci dessous?

Cordialement
0
zatox
Messages postés
641
Date d'inscription
samedi 17 février 2007
Statut
Membre
Dernière intervention
26 juin 2020
64
12 févr. 2016 à 15:20
Bonjour, merci pour votre aide, voici le fichier;
https://www.cjoint.com/c/FBmorV6khbB

Le problème se situe au niveau des colonnes F et G de la feuille recherchev qui contiennent non pas blanc comme je disais mais zéro.

Encore merci pour votre aide.
0

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
zatox
Messages postés
641
Date d'inscription
samedi 17 février 2007
Statut
Membre
Dernière intervention
26 juin 2020
64
12 févr. 2016 à 15:22
Euh pardon je crois qu'il y a un problème sur le fichier que je vous ai envoyé, je ne sais pas pourquoi !!!!
0
diablo13800
Messages postés
2790
Date d'inscription
jeudi 2 juillet 2015
Statut
Membre
Dernière intervention
17 mai 2022
1 775
12 févr. 2016 à 16:05
Votre premiere ligne est sensé sortir 48.39 si je ne me trompe pas?
Si c'est le cas , faite attention , ce n'est pas la colonne 9 . mais la colonne 12 pour sortir le 1 et 13 pour le 48.39 .
Vous avez des colonnes caché, cela fausse le comptage
0
zatox
Messages postés
641
Date d'inscription
samedi 17 février 2007
Statut
Membre
Dernière intervention
26 juin 2020
64
12 févr. 2016 à 18:06
Oh OUI !!! merci beaucoup c'est exactement ça, désolé pour le dérangement, je passe le sujet en résolu.
Encore merci.
0