Formule NB.SI et une condition

Résolu/Fermé
Signaler
-
 MaD -
Bonjour,
Je suis bloquée sur la formule suivante :

Je veux compter le nombre de cellules avec le texte "Ami" des cellules d1 à d200 si dans la colonne E il y a marqué "oui"

j'ai donc la formule =NB.SI(D1:D200;"Ami")
Mais comment je fais pour ajouter la condition oui ?


Merci pour votre aide !

4 réponses

Messages postés
3334
Date d'inscription
samedi 20 juillet 2013
Statut
Membre
Dernière intervention
9 décembre 2016
544
Bonjour,

A partir de la version Excel 2007, tu peux utiliser NB.SI.ENS.
=NB.SI.ENS(D1:D200;"Ami";E1:E200;"oui")

Sinon, tu peux utiliser SOMMEPROD
=SOMMEPROD((D1:D200="Ami")*(E1:E200="oui")*1)

A+
Messages postés
258
Date d'inscription
samedi 2 mai 2009
Statut
Membre
Dernière intervention
16 avril 2020
14
Bonjour,

Je ne comprend pas vraiment comment est présenté votre fichier.

Est-ce que chaque ligne de D possède son propre "oui" à la colonne E ou alors il n'y a qu'un seul oui dans la colonne E qui s'applique à toutes la colonne D ?
Messages postés
3700
Date d'inscription
mercredi 11 février 2009
Statut
Modérateur
Dernière intervention
7 décembre 2021
192
Bonjour,

NB.SI.ENS()

Attention l'ordre du résultat et des tests au sein de la formule est inversé.
super !! Merci la première formule marche très bien !