Fusion de cellules avec chiffres et des 0 dans excel [Résolu/Fermé]

Signaler
Messages postés
7
Date d'inscription
mercredi 3 février 2016
Statut
Membre
Dernière intervention
4 février 2016
-
Messages postés
7
Date d'inscription
mercredi 3 février 2016
Statut
Membre
Dernière intervention
4 février 2016
-
Je fusionne deux ou plus de cellules , un code bancaire IBAN par exemple , en utilisant la formule =B2&C2&D2,et certains 0 disparaissent.... fâcheux...
comment faire ?
derfurst

5 réponses

Messages postés
26120
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
27 juillet 2021
5 998
Bonjour
et si vous nous en disiez un peu plus, ils sont où ces 0 qui s'en vont?
à vous lire
Messages postés
7
Date d'inscription
mercredi 3 février 2016
Statut
Membre
Dernière intervention
4 février 2016

exemple de code IBAN
FR76 3004 7140 0800 0356 3420 125
Les séries de chiffres sont logées chacune dans une cellule
quand je fusionne , le 0 devant le 800 et le 0 devant le 200 disparaissent et le code IBAN ne comporte plus le nombre de chiffres du départ.
Merci
Messages postés
26120
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
27 juillet 2021
5 998
C'est assez curieux qu'Excel puisse vous afficher 0800 dans une cellule (qui est donc nécessairement dub texte puisqu'elle affiche le 1° 0) et le faire disparaître dans la concaténation.
J'ai testé chez moi et si je veux garder 0800 dans une cellule il faut soit qu'elle soit en format texte, soit que je rentre la valeur derrière l'apostrophe; Dans les deux cas, la, concaténation conserve le 0.
Avec la cellule en format num, le 0 devant 800 ne reste pas !

pouvez vous placer un exemple de vos données dans un modèle Excel à déposer sur:
https://www.cjoint.com/
(créer le lien en bas de page / le copier en Haut de page) et revenir le, coller ici dans un prochain message.

à vous lire
crdlmnt
>
Messages postés
26120
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
27 juillet 2021

Je suis vieux mais pas top sur excel
Je crois comprendre
Je vais mettre mes cellules concernées en mode texte avant fusion et cela devrait marcher si je vous comprends bien
Je vous dirai cet après midi
Merci
Cdlt
Messages postés
7
Date d'inscription
mercredi 3 février 2016
Statut
Membre
Dernière intervention
4 février 2016

Bonjour
J'ai mis en mode texte mes cellules documentées; celle pour la fusion en mode standard et j'ai saisi ' avant le 0 dans les cellules qui commencent par 0.
ça marche mais alors je dois intervenir dans toutes les cellules de ma série de 300 RIB IBAN pour y saisir le ' avant le 0.
Auriez-vous une solution pour éviter ce fastidieux travail de saisie modificative ?
Merci
derfurst
Messages postés
26120
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
27 juillet 2021
5 998
Bonjour

tout dépend du nombre de 0 que vous avez en début de cellule (et ça reste curieux que vos cellules "mères" affiche un 0 si elles sont en num il y a (peut être??) une solution, à vérifier car on ne connaît pas vos données

=SI(OU(GAUCHE(B2;1)=0;GAUCHE(B2;1)="0");0&B2;B2)&SI(OU(GAUCHE(C2;1)=0;GAUCHE(C2;1)="0");0&C2;C2)&SI=SI(OU(GAUCHE(D2;1)=0;GAUCHE(D2;1)="0");0$D2;D2)

c'est sans garnatie...
crdlmnt
Messages postés
5569
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
8 juillet 2021
627
Bonjour

Vous pouvez mettre en texte '00 par exemple
Pour une concaténation de cellules
=A1&B1&C1
Messages postés
7
Date d'inscription
mercredi 3 février 2016
Statut
Membre
Dernière intervention
4 février 2016

expliquez moi : mettre en texte : dois-je saisir des O ( lettre O) au lieu d'un chiffre 0 ou faire autrement ?
merci
Messages postés
5569
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
8 juillet 2021
627 >
Messages postés
7
Date d'inscription
mercredi 3 février 2016
Statut
Membre
Dernière intervention
4 février 2016

non '0800 = apostroph zéro huit zéro zéro

http://www.cjoint.com/c/FBdl05DEiux
Messages postés
7
Date d'inscription
mercredi 3 février 2016
Statut
Membre
Dernière intervention
4 février 2016
>
Messages postés
5569
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
8 juillet 2021

Bonjour
j'ai donc fait un essai en mettant en mode texte mes cellules d'origine et en mode standard ma cellule pour fusion.
J'ai effectivement saisi des ' dans les cellules commençant par 0 et ça marche !
Merci, mais maintenant j'ai 300 RIB IBAN bancaires dont je dois préparer toutes les cellules qui commencent par un ou plusieurs 0 ...
N'avez-vous pas une solution ?
Merci d'avance
derfurst
Messages postés
16491
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
21 juillet 2021
3 199
Bonjour

avec une fonction personnalisée
Function fusion_iban(ByRef texto As String) As String
Dim reg As Object
Dim extraction As Object

Set reg = CreateObject("vbscript.regexp")
'on travaille sur toute la cellule
reg.Global = True
'le modèle est des caractères "digitaux ("d") à n chiffres (d?\)
reg.Pattern = "(\d?\d?\d)"
' éxécute l'extraction svt modèle (collection des digits...)
Set extraction = reg.Execute(texto)
For Each digit In extraction
' concaténète les membres de la collection "extraction"
chiffres = chiffres & extrait_chiffres & (digit.Value)
Next digit
fusion_iban = Left(texto, 2) & chiffres
End Function

Messages postés
7
Date d'inscription
mercredi 3 février 2016
Statut
Membre
Dernière intervention
4 février 2016

Merci pour cette réponse mais je dois dire qu'elle est un peu compliquée pour moi.
je reconnais que la formule indiquée par eric est top et ça marche.
Merci de vos conseils
c'est la première fois que je questionne via CCM et je dois dire que c'est suoer.
Merci à vous
à une autre fois
derfurst
Messages postés
24141
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
24 juillet 2021
6 847
Bonjour,

ou par formule :
=A2 & TEXTE(B2;"0000") & TEXTE(C2;"0000") & etc...
sauf "000" pour le dernier qui n'a que 3 chiffres.
eric
Messages postés
7
Date d'inscription
mercredi 3 février 2016
Statut
Membre
Dernière intervention
4 février 2016

Bonsoir
Merci à vous trois VAUCLUSE, PHILOU et eric
Mon problème est résolu avec la formule qui m'a été indiquée par Eric.
cordialement
derfurst