Calcul précis du nombre de mois entre 2 dates

Fermé
TIATIA35 Messages postés 10 Date d'inscription jeudi 21 janvier 2016 Statut Membre Dernière intervention 25 janvier 2016 - 21 janv. 2016 à 11:05
tontong Messages postés 2526 Date d'inscription mercredi 3 février 2010 Statut Membre Dernière intervention 15 novembre 2022 - 25 janv. 2016 à 16:16
bon voila moi je m'arrache les cheveux a effectuer un calcul de mois précis entre 2 dates, mais les formules que j'ai testé jusque là je me donne pas satisfaction. certaine me donne 11.7 pour une date de début au 15/01/2016 et fin au 31/12/2016. mais il se trouve que pour moi ça fait 11.5 De plus quelquefois ma date de début et de fin ne se trouve pas être sur la même année.

l'idée est de trouver une formule qui me permette de calculer efficacement le CA d'un contrat pour appliquer un % de rem. Ce CA est défini tel que : Prix X durée X consommation.

Quelqu'un peut il m'aider ?
A voir également:

4 réponses

Vaucluse Messages postés 26495 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 8 avril 2022 6 284
25 janv. 2016 à 14:03
Bonjour
j'ai depuis peu dans mes tiroirs cette formule qui calcule le nombre de mois complet entre deux dates. Je ne sais pas si elle peut vous servir. Elle est élaborée pour éliminer (au mieux!) les défaillances du code DATEDIF qui n'est pas très au point dans Excel et pose des problèmes de calcul dans certains cas

Pour une date début en A10 et fin en B10
=SIERREUR(SI(JOUR(B10)=31;DATEDIF(A10-1;B10;"m");DATEDIF(FIN.MOIS(A10;0);FIN.MOIS(B10;-1);"m")+SI(JOUR(A10)=1;1;0)+SI(B10>FIN.MOIS(B10;-1);1;0));0)

seuls les mois complets sont comptés

crdlmnt
2
TIATIA35 Messages postés 10 Date d'inscription jeudi 21 janvier 2016 Statut Membre Dernière intervention 25 janvier 2016
25 janv. 2016 à 14:41
merci pour ton concours, mais j'ai a comptabiliser des parties de mois.
0