SOMMEPROD à partir d'aujourd'hui [Résolu/Fermé]

Signaler
-
Messages postés
6
Date d'inscription
vendredi 8 janvier 2016
Statut
Membre
Dernière intervention
8 janvier 2016
-
Bonjour,

Je cherche à calculer un prix moyen.

J'ai actuellement cette formule:
=SOMMEPROD(T7:T37;O7:O37)/O38

Colonne T: Prix
Colonne O: Nombre de chambre
O38: Total de chambre

Le soucis, c'est que souhaiterais que cette formule ne prenne pas en compte les jours qui sont passés. Seulement je ne sais pas ou mettre mon AUJOURDHUI...

Pouvez-vous m'aider?

D'avance merci pour votre aide.

Cordialement,

Amélie

5 réponses

Messages postés
6
Date d'inscription
vendredi 8 janvier 2016
Statut
Membre
Dernière intervention
8 janvier 2016
1
Quand je met cette formule:
=SOMMEPROD((T7:T37)*(O7:O37)*(C7:C37>AUJOURDHUI())/O38)
Cela me donne un prix moyen de 63.31...
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 65492 internautes nous ont dit merci ce mois-ci

Messages postés
32113
Date d'inscription
mercredi 22 octobre 2003
Statut
Modérateur
Dernière intervention
20 avril 2021
3 409
Et selon toi tu devrais avoir combien ?
(je n'ai pas fait le calcul)
Messages postés
6
Date d'inscription
vendredi 8 janvier 2016
Statut
Membre
Dernière intervention
8 janvier 2016
1
En fait vous avez raison, c'est à cause du nombre total de chambre parce que quand je le modifie manuellement dans la formule
=SOMMEPROD((T7:T37)*(O7:O37)*(C7:C37>AUJOURDHUI())/857)
J'obtiens un prix moyen de 76.98 qui me semble cohérent.
Messages postés
32113
Date d'inscription
mercredi 22 octobre 2003
Statut
Modérateur
Dernière intervention
20 avril 2021
3 409 >
Messages postés
6
Date d'inscription
vendredi 8 janvier 2016
Statut
Membre
Dernière intervention
8 janvier 2016

Donc la bonne formule serait :

=SOMMEPROD((T2:T9)*(O2:O9)*(P2:P9>AUJOURDHUI())/SOMMEPROD((O2:O9)*(P2:P9>AUJOURDHUI())))


après avoir modifié les plages de cellules...
Messages postés
5549
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
19 avril 2021
594
Bonjour

Avez-vous une colonne avec les dates
Oui, il s'agit de la colonne C
Messages postés
32113
Date d'inscription
mercredi 22 octobre 2003
Statut
Modérateur
Dernière intervention
20 avril 2021
3 409
Bonjour,


=SOMMEPROD((T2:T9)*(O2:O9)*(P2:P9>AUJOURDHUI())/O11)



NB: remets tes propres coordonnées de cellule... moi j'ai mis les miennes pour les tests.

Cordialement, 
Jordane                                                                 
Merci mais à quoi est censée correspondre la colonne P?
Messages postés
32113
Date d'inscription
mercredi 22 octobre 2003
Statut
Modérateur
Dernière intervention
20 avril 2021
3 409 > AmélieSSRT
Les dates ...
Vu que tu ne nous indiquait pas ....où toi tu les avais mise.... ^^
La formule fonctionne, elle me donne un prix moyen mais qui est inférieur à tous les tarifs que j'ai... Les tarifs que j'ai sont compris entre 70 et 84 et la formule me donne un prix moyen à 63.31...
Je voulais vous mettre une capture d'écran mais je ne peux pas...
Messages postés
32113
Date d'inscription
mercredi 22 octobre 2003
Statut
Modérateur
Dernière intervention
20 avril 2021
3 409 > AmélieSSRT

Je voulais vous mettre une capture d'écran mais je ne peux pas...

TU peux... mais il faut cliquer sur le bouton REPONDRE AU SUJET (et non pas simplement "commenter" )

As tu bien remis toutes les coordonnées de tes différentes plages de cellules ?
Messages postés
6
Date d'inscription
vendredi 8 janvier 2016
Statut
Membre
Dernière intervention
8 janvier 2016
1
http://www.cjoint.com/c/FAipC6nCwvz
Messages postés
6
Date d'inscription
vendredi 8 janvier 2016
Statut
Membre
Dernière intervention
8 janvier 2016
1
Et vous avez raison pour le total de chambre, il ne doit pas prendre en compte les jours passés...
Messages postés
6
Date d'inscription
vendredi 8 janvier 2016
Statut
Membre
Dernière intervention
8 janvier 2016
1
Merci beaucoup!

Vous êtes un dieu en Excel!!
Messages postés
32113
Date d'inscription
mercredi 22 octobre 2003
Statut
Modérateur
Dernière intervention
20 avril 2021
3 409
Oula... un dieu peut être pas .... un demi-dieu à la limite ....
( ... j'ai les chevilles qui enflent....)

Mais merci ^^

PS: Si la question est résolue..
Merci de ne pas oublier de clôturer le sujet
(en cliquant sur le lien "Marquer comme résolu" qui se trouve sous le titre de la question)

Cordialement,
Jordane
Messages postés
6
Date d'inscription
vendredi 8 janvier 2016
Statut
Membre
Dernière intervention
8 janvier 2016
1
Ça y est, c'est clôturé! Encore merci pour votre aide précieuse.
Cordialement.

Amélie