Problème caractères spéciaux

Résolu/Fermé
Essayonsderesoudrelesouci Messages postés 22 Date d'inscription mercredi 30 décembre 2015 Statut Membre Dernière intervention 13 février 2016 - 5 janv. 2016 à 16:38
Essayonsderesoudrelesouci Messages postés 22 Date d'inscription mercredi 30 décembre 2015 Statut Membre Dernière intervention 13 février 2016 - 10 févr. 2016 à 16:12
Bonjour, je vous contacte suite à créations de mon site. explication du problème;
Sur mon PC (en local) mon site affiche correctement les caractères spéciaux. En revanche après avoir envoyé les fichiers de mon site avec Filezilla à mon hébergeur chez 1and1 il y a un problème d'affichage de caractères spéciaux. Mes balises méta de référencement utilisent des caractères spéciaux et c'est ce qui me dérange le plus. si vous avez de solution ça me sauverai la vie ! je vous laisse le code source après publication sur mon hébergeur et aussi en local ( J'utilise Chrome en local) ;

<meta http-equiv="Content-Type" content="text/html; charset="utf-8">
<title>***********************</title>
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<meta name="description" content="************ professionnel ********* sur Lyon et Paris, France. Recommand� par l'�ducation nationale: Photos, vid�os, �v�nementiels, cascades et encadrements.">
<meta name="author" content="********">
<meta name="reply-to" content="contact@*********.com (*********)">
<meta name="robots" content="index, follow">
<meta name="copyright" content="***********">
<meta name="language" content="fr">
<meta name="identifier-url"http://www.*********.com">
<meta name="Keywords" content=" �v�nementiel, lyon, photos, vid�os, cascade, acteur, paris, street, salto, free, run,">


Et le code source affiché en local:
<meta http-equiv="Content-Type" content="text/html; charset="utf-8">
<title>***************</title>
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<meta name="description" content="***************** sur Lyon et Paris, France. Recommandé par l'éducation nationale: Photos, vidéos, événementiels, cascades et encadrements.">
<meta name="author" content="*********">
<meta name="reply-to" content="contact@***********.com (***********)">
<meta name="robots" content="index, follow">
<meta name="copyright" content="***********">
<meta name="language" content="fr">
<meta name="identifier-url"http://***********.com">
<meta name="Keywords" content="**********,événementiel, lyon, photos, vidéos, cascade, acteur, paris, street, salto, free, run, >


Information peut etre utile;
- utilisation de google chrome en local
- utilisation de filezilla
- je suis en transfert de domaine vers le nouveaux j'ai donc publié le site sur une adresse provisoire de mon hébergeur
- Page en .php en http equiv charset utf 8

1 réponse

jordane45 Messages postés 38222 Date d'inscription mercredi 22 octobre 2003 Statut Modérateur Dernière intervention 23 juillet 2024 4 683
5 janv. 2016 à 19:38
Bonjour,

As tu vérifié que ton fichier était bien encodé en utf8 sans BOM ?
https://j-willette.developpez.com/tutoriels/web/encoder-son-site-en-utf8/#LIII

Essayonsderesoudrelesouci Messages postés 22 Date d'inscription mercredi 30 décembre 2015 Statut Membre Dernière intervention 13 février 2016
10 févr. 2016 à 16:12
J'ai finalement opté pour le encodage HTML complet peu importe ma méta ça évite tout les soucis !
0