Fonction SI multiple [Résolu/Fermé]

Signaler
Messages postés
3
Date d'inscription
samedi 2 janvier 2016
Statut
Membre
Dernière intervention
3 janvier 2016
-
Messages postés
3
Date d'inscription
samedi 2 janvier 2016
Statut
Membre
Dernière intervention
3 janvier 2016
-
Bonjour,

J'aimerais effectuer une moyenne avec des SI, j'ai 3 colonnes avec des données et une quatrième qui est censée faire apparaître le résultat.

La première colonne a obligatoirement une donnée, la deuxième peut ne pas en avoir et la troisième peut ne pas en avoir non plus.

Je vais vous faire un exemple avec les 3 situations possibles :

1) colonne 1 = 70 / colonne 2 = 60 / colonne 3 = 50.
2 ) colonne 1 = 70 / colonne 2 = 60 / colonne 3 = pas de donnée ou 0.
3) colonne 1 = 70 / colonne 2 = pas de donnée ou 0 / colonne 3 = pas de donnée ou 0.

J'aimerais que dans chaque situation EXCEL fasse la moyenne des cellules sauf de celles où il y a "0" ou pas de donnée.

Donc dans la 1) j'aimerais que le total soit divisé par 3. Dans la 2) j'aimerais que le total soit divisé par 2 et dans la 3) par 1.

Y'a-t-il une formule qui pourrait réaliser ceci ? J'aimerais autant ne pas avoir à le faire à la main, j'ai 660 lignes à faire donc si EXCEL pouvait le réaliser automatiquement, ça m'arrangerait.

En attendant votre réponse, je vous remercie d'avance.

Très cordialement





2 réponses

Messages postés
9579
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
16 octobre 2020
1 927
Bonjour

Essaies ceci (formule matricielle à valider avec Ctrl+Maj+Entrée - elle se mettra toute seule entre accolades)
données en A2, B2, C2
=MOYENNE(SI(A2:C2<>0;A2:C2))

CDlmnt
Messages postés
3
Date d'inscription
samedi 2 janvier 2016
Statut
Membre
Dernière intervention
3 janvier 2016

Super super ça marche merci beaucoup !!!

Par contre j'ai une autre question, peut-être pourriez-vous y répondre aussi si cela ne vous dérange pas ?

Si jamais je devais insérer un coefficient dans A2, B2 ou C2, comment devrais-je m'y prendre ?

Encore merci à vous.
Messages postés
9579
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
16 octobre 2020
1 927
Les coeff en A1, B1, C1
Les valeurs en A2, B2, C2 (A2 est non vide)
essaies ceci (formule normale (à valider avec Entrée)
=SOMMEPROD((A2:C2);($A$1:$C$1))/SOMMEPROD(($A$1:$C$1)*(A2:C2<>0))

Cdlmnt
Messages postés
3
Date d'inscription
samedi 2 janvier 2016
Statut
Membre
Dernière intervention
3 janvier 2016

Ca marche aussi ! Merci beaucoup ! Je vous souhaite bonne continuation !