Formule pour récupérer une donnée compliquée à repérer [Résolu/Fermé]

Signaler
Messages postés
323
Date d'inscription
mercredi 31 mars 2010
Statut
Membre
Dernière intervention
4 mars 2020
-
Messages postés
323
Date d'inscription
mercredi 31 mars 2010
Statut
Membre
Dernière intervention
4 mars 2020
-
Bonjour à tous,

J'ai un tres gros fichier avec le détail des ventes de l'ensemble de nos produits, le nom du produit n'est pas au bon endroit il faut qu'il soit à coté de chaque vente. Au vue du nombre énorme de produit il me faut une formule qui "repere" le nom du produit pour le mettre au bon endroit et là je n'ai aucune idée pour le faire ... le but étant d'avoir une formule que l'on tire sur les 46 000 lignes ...

Ci joint un fichier pour une meilleure représentation de la problématique https://www.cjoint.com/c/ELijskD6jvs

j'espere que vous pourrez m'aider car là je séche complétement !!
merci d'avance de votre aide :)

cordialement

stephanie

https://www.cjoint.com/c/ELijskD6jvs

2 réponses

Messages postés
5524
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
21 octobre 2020
498
Bonjour

Le fichier ne nous sert pas à grand chose, vous n'avez même pas fourni un exemple de ligne dans laquelle il faut chercher ce mots (carottes)

=CHERCHE("*carottes*";C6;1)

cette formule permet de savoir si "carottes est contenu dans une cellule (C6 )
dans ce cas

=SOMME.SI(B:B;C6;E:E) celle-ci compte la quantité colonne E
correspondant à carottes colonne B total = 300


=SOMME.SI.ENS(E:E;B:B;C6;F:F;F8) pour celle-ci on compte les quantité de carottes pour un client "X"

A vous lire
Messages postés
323
Date d'inscription
mercredi 31 mars 2010
Statut
Membre
Dernière intervention
4 mars 2020
5
merci de votre aide Philou10120
Messages postés
12781
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
21 octobre 2020
2 044
Bonjour stephanie

En D8 mettre la formule :
=SI(E8>0;INDEX(C:C;EQUIV("*";D$1:D7;-1));"")
et l'étirer vers le bas

La formule (s'il y a une valeur >0 en E) recherche avec EQUIV la dernière cellule remplie dans la plage en colonne D précédent la ligne de la formule (donc celle où il y a marqué date) et renvoie avec INDEX la valeur sur la même ligne de la colonne C (donc le produit)

Cdlmnt
Via
Messages postés
323
Date d'inscription
mercredi 31 mars 2010
Statut
Membre
Dernière intervention
4 mars 2020
5
OUHA !!!! Merci mille fois ca fonctionne à merveille !!!! c'est vraiment super !
vous me sortez une belle épine du pied :)
Messages postés
323
Date d'inscription
mercredi 31 mars 2010
Statut
Membre
Dernière intervention
4 mars 2020
5
j'ai un peu de mal à l'adapter à mon fichier...
https://www.cjoint.com/c/ELikMwo7J7s
si vous pouvez m'aider une derniere fois ...
Messages postés
12781
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
21 octobre 2020
2 044 >
Messages postés
323
Date d'inscription
mercredi 31 mars 2010
Statut
Membre
Dernière intervention
4 mars 2020

Re,

La présentation du fichier est différente, la formule précédente ne peut pas fonctionner.

Donc (et c'est plus simple) en B14 mettre cette formule puis l'étirer vers le bas :
=SI(B13="Date";B12;SI(B14<>"";A13;""))

Cdlmnt
Via
Messages postés
323
Date d'inscription
mercredi 31 mars 2010
Statut
Membre
Dernière intervention
4 mars 2020
5
fantastique !!!!!!!!!!!!!! merciiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiii !!!