Incrémenter une liste en fonction des lignes identiques

Résolu/Fermé
Seb - 1 déc. 2015 à 17:26
 Seb - 2 déc. 2015 à 16:15
Bonjour,

Je souhaiterais faire une liste de prestations que j'ai en fonction des cellulles, sachant que 1 prestation correspond à 1 ligne. Je vous trouver quelles sont les lignes qui ont exactement les mêmes colonnes et savoir combien (créer un liste)

Voici un exemple avec en jaune le résultat d'une cellule que j'aimerais mettre en place: http://www.cjoint.com/c/ELbqzSI2wZW

Merci d'avance.

2 réponses

Vaucluse Messages postés 26496 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 1 avril 2022 6 407
Modifié par Vaucluse le 1/12/2015 à 17:52
Bonsoir
je peux vous proposer cette formule en H2 en plaçant auparavant 1 en H1 et en tirant sur la hauteur
=SI(NB.SI($I$1:I2;I2)=1;MAX($H$1:H1)+1;INDEX($H$1:H1;EQUIV(I2;$I$1:I1;0)))

mais j'ai un problème de logique sur le N° 6 en jaune de la jaune de G11 où ; come le texte est identiques au 2° précédent, la formule ressort 2 (ce qui décale les N° suivant) ?

voila le résultat
https://www.cjoint.com/c/ELbqZAR7aJ5
(attention la formule commence en H2)

crdlmnt

Errare humanum est, perseverare diabolicum
Oui ca fonctionne.
En revanche, est il possible de mettre à jour la liste en fonction du nombre d'égalité ? En l’occurrence 8 dans votre exemple.
0
Vaucluse Messages postés 26496 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 1 avril 2022 6 407
1 déc. 2015 à 18:11
pas compris, vous pouvez préciser?
0
La liste se trouve en dessous, elle reprend les numéros du dessus et les remet dans l'ordre
0
Vaucluse Messages postés 26496 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 1 avril 2022 6 407
2 déc. 2015 à 12:53
Oui merci ! C'est normal que la plage verte ne prenne que a partie de la 2e ligne ?
0
Vaucluse Messages postés 26496 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 1 avril 2022 6 407
Modifié par Vaucluse le 2/12/2015 à 13:09
Non, c'est une erreur, habitué aux tableau avec des titres, j'ai débuté sur la ligne 2 sans regarder le haut
corrigez dans la formules des deux plages bleues,en H23 et I23, les I2 et H2 en I1 et H1 en respectant bien les signes $
et tirer sur la hauteur
crdlmnt
0
Merci niquel !

Bonne journée
0
Je viens d'ajouter des lignes avant mon tableau et la liste du dessous ne marche plus...

Çà vient du A1 de la formule ?
0