Référence onglet autre fichier en fonction valeur d'une cellule

Résolu/Fermé
comi60 - 28 nov. 2015 à 10:16
Vaucluse Messages postés 26495 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 8 avril 2022 - 28 nov. 2015 à 13:30
Bonjour,

Je cherche la syntaxe pour définir une plage dans un autre fichier sur un onglet où le nom de l'onglet est défini en fonction de la valeur d'une cellule.
Ex :

A1 = nom de l'onglet
A2 = NB.SI('[classeur1.xlsx]Feuil1'!$A$1:$B$10,F10)>0

Je cherche à remplacer Feuil1 par la valeur de la cellule A1 mais sans succès.

merci d'avance de votre aide!


2 réponses

Vaucluse Messages postés 26495 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 8 avril 2022 6 273
28 nov. 2015 à 10:19
Bonjour

= NB.SI(INDIRECT("'[classeur1.xlsx]"&A1&"'!$A$1:$B$10"),F10)>0
attention aux signes

crdlmnt
0
Merci de votre réponse. Par contre j'ai comme réponse #réf. Je pense que j'ai fait une erreur de syntaxe avec les signes...
Pouvez vous me dire si vous voyer quelque chose?

=SI(NB.SI(INDIRECT("'[Radar charts all pillar leaders nov 2015 - last version - vierge.xlsx]"&C39&"'!$D$1:$F$360"),F10)>0,1,0)

Cordialement
0
Vaucluse Messages postés 26495 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 8 avril 2022 6 273
28 nov. 2015 à 11:42
vois rien de spécial si le nom de feuille est bien en C39, mais il faut que le classeur source soit ouvert, est ce le cas?
0
C'est bon j'ai réussi! Merci beaucoup! Par contre je n'ai pas compris où était mon erreur...
0
Vaucluse Messages postés 26495 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 8 avril 2022 6 273
28 nov. 2015 à 13:30
Probablement une faute de frappe , ou une virgule au mauvais endroit, un fichier fermé", va savoir!?
L'essentiel étant que ça fonctionne comme vous le souhaitez
je passe le sujet en résolu
Bonne route
crdlmnt
0