ProFTPd (sous MySQL) - Connexion FileZilla [Fermé]

Signaler
Messages postés
37
Date d'inscription
samedi 25 avril 2015
Statut
Membre
Dernière intervention
3 novembre 2016
-
Messages postés
37
Date d'inscription
samedi 25 avril 2015
Statut
Membre
Dernière intervention
3 novembre 2016
-
Bonjour,

Pour commencer ma conf et mes versions :
- FileZilla: 3.14.1
- SRV: VPS de chez OVH
- Distrib: Debian 7
- Certificats SSL: OUI

- Options de /etc/proftpd/proftpd.conf :
UseIPv6 off
IdentLookups off
ShowSymlinks off
DefaultRoot ~
Port 21
Include /etc/proftpd/conf.d/
AllowStoreRestart on
AllowRetrieveRestart on


Le reste est inchangé. Lors d'un "restart" de ProFTPd je n'ai pas d'erreur.

Voici le message de FileZilla:
Statut : Résolution de l'adresse de MON_VPS.ovh.net
Statut : Connexion à MON_IP:21...
Statut : Connexion établie, attente du message d'accueil...
Statut : Initialisation de TLS...
Statut : Vérification du certificat...
Statut : Connexion TLS établie.
Commande : USER MON_USER
Réponse : 331 Mot de passe requis pour MON_USER
Commande : PASS ***************
Erreur : Erreur GnuTLS -110: The TLS connection was non-properly terminated.
Statut : Le serveur n'a pas correctement fermé la connexion TLS
Erreur : Impossible d'établir une connexion au serveur

Je pense que c'est tout ce qu'il y a à savoir...

Donc j'aimerais savoir pourquoi je n'arrive pas à me connecter.
Suis dépité, suis à mon 24ème jour de conf de ce VPS !!!


Merci 1000 fois pour l'aide que vous pourrez m'apporter ;)

2 réponses

Messages postés
3003
Date d'inscription
vendredi 18 juin 2004
Statut
Contributeur
Dernière intervention
7 mars 2018
375
Bonjour,

Je ne comprends pas bien ce que vous cherchez à faire.

Vous parlez de Proftpd , de Mysql, et dans le post, on voit une erreur TLS...

Vous ne dites pas tout ;-)

1. Que cherchez vous à faire ?
2. Où est Mysql ici ?
3. Avez vous configuré le mode TLS de Proftpd ?

Parce que bon, le FTPS c'est de la daube :)
On a SSH, et son implémentation SFTP bien plus pratique.
Messages postés
3003
Date d'inscription
vendredi 18 juin 2004
Statut
Contributeur
Dernière intervention
7 mars 2018
375
un autre pour la route, qui explique où configurer le TLS ; on cherche à le désactiver pour l'instant.

http://doc.ubuntu-fr.org/proftpd_et_tls_ssl
Messages postés
37
Date d'inscription
samedi 25 avril 2015
Statut
Membre
Dernière intervention
3 novembre 2016

Hello Kelux,

Donc j'ai dû aller jusqu'à /etc/proftpd/tls.conf pour mettre "off" "TLSEngine" sinon il me le prenait même en mettant "off" "TLSRequired"... anyway (mais ça peut être une info...)

Donc effectivement filezilla ne me donne plus le même message:
Statut : Connexion sur IP_DU_VPS...
Statut : Connexion établie. Attente du message d'accueil...
Réponse : 220 ProFTPD 1.3.4a Server (Debian) [IP_DU_VPS]
Commande : USER admin_XXXXXXX
Erreur : Délai d'attente expiré
Erreur : Connexion au serveur impossible !
Statut : Attente avant nouvel essai...
Statut : Connexion sur IP_DU_VPS:21...
Statut : Connexion établie. Attente du message d'accueil...
Réponse : 220 ProFTPD 1.3.4a Server (Debian) [IP_DU_VPS]
Commande : USER admin_XXXXXXX
Erreur : Délai d'attente expiré
Erreur : Connexion au serveur impossible !

En attendant je me documente ;)
Messages postés
3003
Date d'inscription
vendredi 18 juin 2004
Statut
Contributeur
Dernière intervention
7 mars 2018
375 >
Messages postés
37
Date d'inscription
samedi 25 avril 2015
Statut
Membre
Dernière intervention
3 novembre 2016

Donc j'ai dû aller jusqu'à /etc/proftpd/tls.conf pour mettre "off" "TLSEngine" sinon il me le prenait même en mettant "off" "TLSRequired"... anyway (mais ça peut être une info...)
Coté client : il y aussi comment le client Filezilla se connecte, s'il essayait en FTPS, ba on ne verra pas de changement. (qui plus est en mode implicite).
Messages postés
3003
Date d'inscription
vendredi 18 juin 2004
Statut
Contributeur
Dernière intervention
7 mars 2018
375
Il va falloir travailler sur le filtrage à présent.
Ce qui est étrange c'est qu'on devrait avoir au moins la commande PASS qui devrait passer avant le délai d'attente expiré.
Je vais préparer ça.
Messages postés
3003
Date d'inscription
vendredi 18 juin 2004
Statut
Contributeur
Dernière intervention
7 mars 2018
375
Il me faudrait la plage de ports passifs ... il faut la mettre dans le filtrage quand on fait les choses jusqu'au bout.
Messages postés
3003
Date d'inscription
vendredi 18 juin 2004
Statut
Contributeur
Dernière intervention
7 mars 2018
375
Et voila !
J'ai fait ça de tête sans le tester ... mais ça devrait le faire.


# Variables
net=eth0

### FTP ###

# Modules
modprobe ip_conntrack
modprobe ip_conntrack_ftp

# FTP Server
iptables -A INPUT -i $net -p tcp --dport 21 -m state --state NEW,ESTABLISHED -j ACCEPT
iptables -A OUTPUT -o $net -p tcp --sport 21 -m state --state ESTABLISHED -j ACCEPT

# FTP server - Active Mode
iptables -A INPUT -i $net -p tcp --dport 20 -m state --state ESTABLISHED -j ACCEPT
iptables -A OUTPUT -o $net -p tcp --sport 20 -m state --state RELATED,ESTABLISHED -j ACCEPT

# FTP server - Passive Mode - Server Range 30000:35000
iptables -A INPUT -i $net -p tcp --sport 1024: --dport 30000:35000 -m state --state RELATED,ESTABLISHED -j ACCEPT
iptables -A OUTPUT -o $net -p tcp --sport 30000:35000 --dport 1024: -m state --state ESTABLISHED -j ACCEPT


# FTP Client (this host needs to connect to other FTP servers - updates...)
iptables -A INPUT -i $net -p tcp --sport 21 -m state --state ESTABLISHED -j ACCEPT
iptables -A OUTPUT -o $net -p tcp --dport 21 -m state --state NEW,ESTABLISHED -j ACCEPT

# FTP client - Active Mode
iptables -A INPUT -i $net -p tcp --sport 20 -m state --state RELATED,ESTABLISHED -j ACCEPT
iptables -A OUTPUT -o $net -p tcp --dport 20 -m state --state ESTABLISHED -j ACCEPT

# FTP client - Passive Mode
iptables -A INPUT -i $net -p tcp --sport 1024: --dport 1024: -m state --state ESTABLISHED -j ACCEPT
iptables -A OUTPUT -o $net -p tcp --sport 1024: --dport 1024: -m state --state RELATED,ESTABLISHED -j ACCEPT





Using a registry "compactor" on top of a registry "cleaner" would be equivalent to rinsing your throat with a swig of Jack Daniels after swallowing a pint of snake oil....
Messages postés
37
Date d'inscription
samedi 25 avril 2015
Statut
Membre
Dernière intervention
3 novembre 2016

Hello Kelux,

Je te remercie... ça ne change rien du tout :(
En écrivant ça je dis que suis mauvais (pas toi). Vais donc remonter le serveur de A à Z en commençant par vérifier si proftpd fonctionne sans le module mysql "proftpd-mod-mysql"... Bref vais faire du step by step avec vérif systématique ;)

J'ai créer une sauvegarde donc si tu as une tite idée lumineuse qui pourrait bloqué le fonctionnement du VPS selon le tuto que j'ai suivi (lien dans les échanges précédents), suis preneur ;)

Merci encore de ta collaboration !
Messages postés
3003
Date d'inscription
vendredi 18 juin 2004
Statut
Contributeur
Dernière intervention
7 mars 2018
375
Attention, il faut modifier la plage de ports passifs dans le script.
Je l'ai demandé à 3 reprises, sans jamais avoir de réponses de ta part.

Sans messages d'erreurs il sera difficile de diagnostiquer ce qui ne va pas.

Il y a des logs pour proftpd , c'est la premiere chose à lire en cas d'erreur.


Plusieurs possibilités : filtrage (et ça y ressemble fortement)
ou
pb de connexion à la base sql. Il faut la tester ...

-

Après pour les tutos, ba j'en utilise rarement ; je préfère la documentation du produit.
Messages postés
37
Date d'inscription
samedi 25 avril 2015
Statut
Membre
Dernière intervention
3 novembre 2016

Hello,

Je n'ai pas pu recommencé par contre je me suis documenté (c'est pour cela que je ne'ai pas recommencé).

- Pour la plage des ports passifs, si je ne t'ai pas répondu ou à côté c'est que je n'ai pas compris ce que tu voulais réellement et surtout où le trouver ;) => Vais voir ça

- Vais aussi vérifier les logs de proftpd

- Pour la connexion à la base SQL ça m'a l'air de fonctionner: j'ai créé une DB simple dans MySQL et un script qui demande le renvoi des infos de cette DB et ça s'est affiché normalement pour le site par défaut.