Moyenne avec case vide [Résolu/Fermé]

Signaler
Messages postés
160
Date d'inscription
samedi 29 octobre 2011
Statut
Membre
Dernière intervention
8 août 2018
-
Messages postés
160
Date d'inscription
samedi 29 octobre 2011
Statut
Membre
Dernière intervention
8 août 2018
-
Bonjour/Bonsoir,

J'ai un petit problème de programmation, en effet, j'essaie de faire un fichier excel afin de calculer une moyenne.
Poser le calcul, le me pose aucun problème, mais j'aimerai que si la case est vide (ou l'intitulé "NPC" >Non Prit en Charge), alors que la moyenne ne prennent pas en compte la case vide.
Voici la base de ma ligne de code:
=SIERREUR((B1*B19+C1*C19+D1*D19+E1*E19+F1*F19+G1*G19+H1*H19+I1*I19+J1*J19+K1*K19)/SOMME(B1:K1);"")

Qu'est ce que je dois modifier sur ma formule afin que si B19/C19/D19ect.. soit vide, alors la moyenne exclu cette valeur.
B1/C1/ect.. >> correspondent au coefficient

Je sais pas si il y a une solution à mon problème. Mais j'ai fait plusieurs forums, mais je n'ai rien trouvé, ou alors j'ai pas compris.

Pouvez vous m'aider ? J'espère que j'ai été clair dans mon explication.

Merci d'avance

Cordialement

2 réponses

Messages postés
17159
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
9 août 2020
4 167
Bonsoir,

pas tout compris, d'après ce que je comprends, cela implique que les cellules ligne 1 et ligne 19 sont parallèlement renseignées

=SOMME(B1*B19+C1*C19;D1*D19;E1*E19;F1*F19;G1*G19;H1*H19;I1*I19;J1*J19;K1*K19)/NB.SI(B19:K19;"<>")
3
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 57491 internautes nous ont dit merci ce mois-ci

Messages postés
160
Date d'inscription
samedi 29 octobre 2011
Statut
Membre
Dernière intervention
8 août 2018
5
Parfait merci beaucoup !
Messages postés
12480
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
10 août 2020
1 963
Bonsoir

Tu peux utiliser SOMMEPROD (ce qui permet déjà de raccourcir ta formule) et d'introduire une critère sur les intitulés
Le total des coefficients sera trouvé avec SOMME.SI pour avoir aussi un critère sur els intitulés
Exemple , à adapter à ton fichier :
http://www.cjoint.com/c/EJhtGXEDpJ3

Cdlmnt
Via
Messages postés
160
Date d'inscription
samedi 29 octobre 2011
Statut
Membre
Dernière intervention
8 août 2018
5
Ok merci, j'étudierai ton dossier demain car là j'ai plus beaucoup de temps. Merci bien, je te tiens au courant de mon avancé.