Excel recherche formule [Résolu/Fermé]

Signaler
Messages postés
8
Date d'inscription
mercredi 7 octobre 2015
Statut
Membre
Dernière intervention
24 mai 2016
-
Messages postés
17293
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
24 octobre 2020
-
Bonjour

Je recherche une fonction Excel qui me permettrait de trouver automatiquement le mois de 1ere commande par client.
Le tableau est fait de la manière suivante :
En colonne : les mois de commandes
En ligne : les clients
En valeur : les montants de chaque commande
Je cherche une formule qui me donnerai donc le mois de la première commande par client.
Auriez-vous une idée ?

Merci d'avance.

8 réponses

Messages postés
2811
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
25 octobre 2020
385
Bonjour,

essaye ça :

{=MIN(SI(COLONNE DU CLIENT<>0;COLONNE DES MOIS)} en matricielle
Messages postés
17293
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
24 octobre 2020
4 307
Bonjour,

si les dates sont croissantes essaye comme cela
=RECHERCHEV(E2;A2:B10;2;0)
Messages postés
8
Date d'inscription
mercredi 7 octobre 2015
Statut
Membre
Dernière intervention
24 mai 2016

Bonjour,

Merci pour vos réponses. Ca n'a pas l'air de fonctionner.
Je vous met en pièce jointe un exemple de fichier simplifié.

Je voudrais qu'en cellule O2 apparaisse 'mars', en cellule O3 'novembre' et en cellule O4 'août'.

Merci.
Messages postés
25444
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
26 octobre 2020
5 552
Bonjour
pour que l'on puisse avoir accès au fichier joint (à qui, à quoi?) il faudrait coller un lien dans un prochain message.
A vous lire
crdlmnt
Messages postés
17293
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
24 octobre 2020
4 307
Re,

tu n'as pas collé le lien de ton fichier
envoi ton fichier à partir de
https://www.cjoint.com/
A+
Mike-31

Une période d'échec est un moment rêvé pour semer les graines du savoir.
Messages postés
8
Date d'inscription
mercredi 7 octobre 2015
Statut
Membre
Dernière intervention
24 mai 2016

Oups, désolée,
Voilà le lien :
http://www.cjoint.com/c/EJhkxs8lIQo
Messages postés
25444
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
26 octobre 2020
5 552
Re

en attendant quelque chose de mieux qui va surement arriver (je fais confiance à l'ami Mike, salut):

=SI(B2>0;$B$1;SI(C2>0;$C$1;SI(D2>0;$D$1;SI(E2>0;$E$1;SI(F2>0;$F$1;SI(G2>0;$G$1;SI(H2>0;$H$1;SI(I2>0;$I$1;SI(J2>0;$J$1;SI(K2>0;$K$2;SI(L2>0;$L$1;"")))))))))))

pour excel à partir de 2007 seulement, vu le nombre de SI

crdlmnt
Messages postés
17293
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
24 octobre 2020
4 307
Re, salut l'ami Vaucluse,

en O2 colle cette formule matricielle que tu devras confirmer en cliquant en même temps sur trois touches Ctrl, Shift et Entrée, si tu fais bien la formule se placera entre ces accolades {} et incrémente la formule vers le bas

=INDIRECT(ADRESSE(1;EQUIV(INDEX(B2:M2;EQUIV(VRAI;B2:M2<>"";0));A2:M2;0)))

si tu as des lignes vides afin d'éviter le message d'erreur #N/A

suivant ta version d'Excel il est possible d'écrire
=SIERREUR(INDIRECT(ADRESSE(1;EQUIV(INDEX(B2:M2;EQUIV(VRAI;B2:M2<>"";0));A2:M2;0)));"")

A+
Mike-31

Une période d'échec est un moment rêvé pour semer les graines du savoir.
Messages postés
2811
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
25 octobre 2020
385
bonjour a tous,

ou bien :

{=INDEX($B$1:$M$1;MIN(SI(($B2:$M2)<>0;COLONNE($A:$L))))}
Messages postés
17293
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
24 octobre 2020
4 307
Salut DjiDji59430,

seul bémol, les lignes vides affichent Janvier qu'il convient de traiter avec une conditionnelle si c'était le cas
cordialement
Messages postés
8
Date d'inscription
mercredi 7 octobre 2015
Statut
Membre
Dernière intervention
24 mai 2016

Super, Merci beaucoup pour votre aide ! :)