Formule voulant afficher du texte en indice

Fermé
Lerak92 - 27 sept. 2015 à 14:22
PHILOU10120 Messages postés 6373 Date d'inscription lundi 16 avril 2012 Statut Contributeur Dernière intervention 17 mai 2024 - 27 sept. 2015 à 15:52
Bonjour,

Je travaille actuellement sur une feuille de calcul excel. Cette feuille devant être disponible en plusieurs langues, j'ai créé une feuille "langage", contenant tous les termes utilisés avec leur traduction, et une formule de sorte que si lange = 1, renvoyer terme colonne B, si langue = 2, renvoyer terme colonne C....

Du coup, dans ma feuille de calcul principale, tout le texte cache en fait la formule suivante:

=Langage!$A$ numéro de ligne du terme

le problème, c'est que cette formule ne respecte pas les écritures en indice ou en exposant. "R²" devient "R2" par exemple.

Existe-il une formule ou une option à cocher qui permettrait de conserver le format originel du texte?

Bien à vous

A voir également:

2 réponses

via55 Messages postés 14417 Date d'inscription mercredi 16 janvier 2013 Statut Membre Dernière intervention 25 mai 2024 2 707
Modifié par via55 le 27/09/2015 à 15:35
Bonjour

Je ne pense pas qu'il existe cela, il faut sans doute passer par du VBA pour faire un copier coller qui conservera le format original

Tout dépend de la structure de ton fichier, pour pouvoir t'en dire plus il en faut une exemple, à poster sur cjoint.com, faire créer un lien, le copier et revneir l'indiquer ici

Cdlmnt
Via

"L'imagination est plus importante que le savoir." A. Einstein
0
PHILOU10120 Messages postés 6373 Date d'inscription lundi 16 avril 2012 Statut Contributeur Dernière intervention 17 mai 2024 800
27 sept. 2015 à 15:52
Bonjour

Si vous utilisez la fonction RECHERCHEV et RECHERCHEH imbriquées la formule renvoie bien R²

=RECHERCHEV("texte cherché";A6:F17;RECHERCHEH(A1;A5:F5;1;FAUX))

la colonne A cellule 6 contient le premier texte à traduire
le texte traduit en colonne B à F suivant la langue
la colonne de la langue choisie en A1 dans ma formule
valeur de la colonne en A5 à F5 pour les langues B=2 pour la première, C=3
D=4 ect...

0