Problème de valeur avec fonction rang

Résolu/Fermé
rorocr Messages postés 81 Date d'inscription mardi 8 septembre 2015 Statut Membre Dernière intervention 8 juin 2022 - 13 sept. 2015 à 21:24
rorocr Messages postés 81 Date d'inscription mardi 8 septembre 2015 Statut Membre Dernière intervention 8 juin 2022 - 14 sept. 2015 à 13:30
Bonjour,

Voici mon problème: j'ai une plage de 20 cellules qui sont classées avec la fonction rang! J ai besoin de comparer les résultats de la fonction rang pour savoir entre 2 cellules laquelle comporte la valeur la plus petite!

Exemple: a1=16 (rang 16) et b1=7 (rang7)
Je mets en c1 =si(a1>b1;"logique respectée";"problème") et le résultat de la formule donne "problème" alors que 16 est bien supérieur à 7

Quelqu un peut il m'aider ?

Merci d avance

A voir également:

2 réponses

Frenchie83 Messages postés 2239 Date d'inscription lundi 6 mai 2013 Statut Membre Dernière intervention 28 janvier 2023 333
14 sept. 2015 à 07:05
Bonjour
Quel est l'utilité des parenthèses dans les colonnes des rangs? Supprimez-les et ça ira beaucoup mieux,.
Si vous ne pouvez pas supprimer les parenthèses alors remplacez par ceci
en J1 et à tirer vers le bas
=SI(SUBSTITUE(SUBSTITUE(Tableau4[ligne;[rang]];"(";"");")";"")*1<SUBSTITUE(SUBSTITUE(Tableau4[ligne;[rang2]];"(";"");")";"")*1;"logique respectée";"surprise")
Cdlt
1
Vaucluse Messages postés 26495 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 8 avril 2022 6 306
Modifié par Vaucluse le 14/09/2015 à 08:21
Bonjour
un petit exploit d'Excel (va savoir pourquoi?) avec cette formule:

=SI(D2*-1>G2*-1;"Logique respectée";"surprise")

qui, renverra surprise quand la valeur de Rang2 est supérieure à celle de Rang, et Logique respectée dans le cas contraire
(sinon inversez le signe >)

Non?

crdlmnt
0
rorocr Messages postés 81 Date d'inscription mardi 8 septembre 2015 Statut Membre Dernière intervention 8 juin 2022 1
14 sept. 2015 à 13:30
Merci beaucoup pour ton astuce, ca marche nickel
0
via55 Messages postés 14032 Date d'inscription mercredi 16 janvier 2013 Statut Membre Dernière intervention 27 janvier 2023 2 548
13 sept. 2015 à 22:45
Bonsoir

Apparemment pas d'erreur dans la formule, le problème doit venir des données dans le fichier qu'il faudrait avoir pour te dire où

Postes un exemple de ton fichier sur cjoint.com, fais créer un lien, copies-le et reviens l'indiquer ici

Dans l'attente
Cdlmnt
Via
0
rorocr Messages postés 81 Date d'inscription mardi 8 septembre 2015 Statut Membre Dernière intervention 8 juin 2022 1
14 sept. 2015 à 00:41
bonsoir,

voila un exemple de fichier
https://www.cjoint.com/c/EInwPDgLVPQ

merci encore
0