Fonction SI pour donner un code couleur par ecart de date [Résolu/Fermé]

Signaler
-
 mam721 -
Bonjour à tous,


Je souhaiterais avoir un peu d'aide lors de la formulation de la fonction SI.

J'ai un tableau de ce type :
[img]http://nsa38.casimages.com/img/2015/08/27/150827123255206891.jpg/img

Je souhaiterais mettre une fonction qui me calcule la différence entre la date d'échéance et la date de livraison. Puis en fonction de l'écart entre les deux, de mettre vert/jaune/orange/rouge comme statut.

Le statut dépend de ces conditions : si C2 est
=<B2 VERT -> si la date de livraison est avant la date d'échéance alors mettre statut vert
>B2;=<B2+3 JAUNE -> si la date de livraison est comprise entre la date d'échéance et date d'échéance+3 alors statut Jaune
>B2+3;<B2+7 ORANGE -> si la date de livraison est comprise entre la date d'échéance+3 et date d'échéance+7 alors statut Orange
>B2+7 ROUGE -> si la date de livraison est après la date d'échéance+7 alors statut Rouge

Je pensais utiliser la fonction SI comme suit :
=SI(C2<=B2;"Vert";SI(C2<=(B2+3));"Jaune";SI(C2<(B2+7));"Orange";SI(C2>(B2+7°."Rouge")))

Je sais que je merde quelque part mais je ne voit pas ou. Pouvez vous me dire ou je me suis trompé ?

Je vous remercie par avance.

Cordialement.
Mam721

2 réponses

Messages postés
12870
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
1 décembre 2020
2 081
Bonsoir,

Il y a des parenthèse en trop, essaie :
=SI(C2<=B2;"Vert";SI(C2<=B2+3;"Jaune";SI(C2<=B2+7;"Orange";"Rouge")))

Cdlmnt
Via
2
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 76687 internautes nous ont dit merci ce mois-ci

Bonjour Via,

C'est le résultat que je cherchais.
Je vous remercie pour votre aide et pour votre reactivité.
Mon problème est résolu.

Cordialement.
Mam721
Messages postés
52778
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
2 décembre 2020
14 726
Bonjour.

Tu t'es trompé à plusieurs endroits :
1) au milieu, en oubliant le cas où C2=B2+7
2) à la fin, en oubliant la dernière condition,
3) un peu partout, en ajoutant des parenthèses parasites, comme signalé par via55 (salut à toi !)
=SI(C2<=B2;"Vert";SI(C2<=B2+3;"Jaune";SI(C2<
 = 
B2+7;"Orange";SI(C2>B2+7;"Rouge"
 ;"aucune couleur") 
)))


Et au niveau du raisonnement logique, si tu as déjà étudié tous les cas où C2 est inférieur à B2+7, à quoi sert d'ajouter un quatrième test pour le cas où C2 serait supérieur ? On aboutit ainsi à la formule donnée par via55.

Cordialement.
Bonjour Raymond,

Je vous remercie pour les explications.
J'éviterais à l'avenir de mettre des parenthèses pour un calcul X+3.


Merci pour votre aide.
Cordialement,
Mam721