Erreur excel, formule somme.si [Résolu/Fermé]

Signaler
Messages postés
63
Date d'inscription
vendredi 11 juillet 2014
Statut
Membre
Dernière intervention
21 septembre 2018
-
Messages postés
63
Date d'inscription
vendredi 11 juillet 2014
Statut
Membre
Dernière intervention
21 septembre 2018
-
Bonjour,

J'ai le pack office 2007.
J'ai un petit souci avec une formule sur excel : somme.si

Voici la formule que j'ai tapé dans ma case E28 :
=SOMME.SI(A21;"X";G23:G25)

Si je mets un "X" dans la case A21,
Dans la case E28, j'ai uniquement G23
Ca ne fait pas l'addition avec les cases G24 et G25

Je ne comprends pas d'où vient le problème.
Si vous pouviez m'aider, ce serait super.

Merci d'avance

2 réponses

Messages postés
11910
Date d'inscription
mardi 24 mai 2011
Statut
Contributeur
Dernière intervention
12 juin 2018
2 280
Il faut que la zone de référence (A21) ait la même taille et la même forme que la zone que tu additionnes (G23:G25)

En E28, j'écrirais plutôt une formule du genre =SI(A21="X";somme(G23:G25);0)
Messages postés
63
Date d'inscription
vendredi 11 juillet 2014
Statut
Membre
Dernière intervention
21 septembre 2018
1
Ca fonctionne en utilisant votre formule.
Merci beaucoup.