Exclure de la moyenne les cellules 0 dans MOYENNE.SI.ENS [Résolu/Fermé]

Signaler
Messages postés
18
Date d'inscription
vendredi 24 juillet 2015
Statut
Membre
Dernière intervention
17 novembre 2015
-
Messages postés
2690
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
29 juillet 2020
-
Bonjour,

J'ai un petit problème avec la formule MOYENNE.SI.ENS.
Je souhaite dans cette formule, qui me fait ma moyenne sur plusieurs critères, exclure les cellules contenant zéro pour ne pas fausser ma moyenne.

Ma formule est : =SI(U9=0;"";MOYENNE.SI.ENS(BDD!BD7:BD24;BDD!$H$7:$H$24;$E$16;BDD!$J$7:$J$24;"*"&$I$11&"*";BDD!$K$7:$K$24;$E$21;BDD!$L$7:$L$24;$E$20;BDD!$M$7:$M$24;$E$19))

Ou plus simplement :
=MOYENNE.SI.ENS(BDD!BD$7:BD$24;BDD!$H$7:$H$24;$E$16)

En attendant avec impatiente vos réponses.

Si je ne suis pas assez claire dites le.

1 réponse

Messages postés
2690
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
29 juillet 2020
357
Bonjour,

{=MOYENNE(SI(((bdd!BD$7:BD$24<>0)*(BDD!$H$7:$H$24=$E$16))<>0;bdd!BD$7:BD$24))}

en matricielle
Messages postés
18
Date d'inscription
vendredi 24 juillet 2015
Statut
Membre
Dernière intervention
17 novembre 2015

Bonjour DjiDji, je ne comprend pas vraiment la formule.

Comment la passer en matricielle?
Messages postés
2690
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
29 juillet 2020
357 >
Messages postés
18
Date d'inscription
vendredi 24 juillet 2015
Statut
Membre
Dernière intervention
17 novembre 2015

re

en faisant shift+control+entrée pour valider la formule (a la place de enter=