Mise en forme conditionnelle basée sur une plage de données

Fermé
Levecteur Messages postés 18 Date d'inscription mercredi 20 mars 2013 Statut Membre Dernière intervention 18 septembre 2018 - 30 juil. 2015 à 22:59
Levecteur Messages postés 18 Date d'inscription mercredi 20 mars 2013 Statut Membre Dernière intervention 18 septembre 2018 - 1 août 2015 à 13:56
Bonsoir Chère équipe,

J'aimerais bien bénéficier de votre éclairage.

1) Comment puis je appliquer une mise en forme conditionnelle à un tableau de
nombres avec pour principe que la mise en forme soit effective uniquement pour les valeurs du tableau qui ont leur équivalent dans la plage de cellules?

A titre d'illustration ci dessous, j'aimerais appliquer une mise en forme ligne par ligne pour les valeurs Ti qui ont un équivalant dans les valeurs Pi

T1 T2 T3 T4 T5 T6 T7 P1 P2 P3 P4 P5 P6
07 05 09 15 12 02 03 08 13 03 16 09 07
08 09 11 05 07 06 16 08 04 05 09 06 12
07 05 09 15 12 02 03 04 12 07 10 02 03

Peut-on recopier cette mise en forme parallèlement lignes suivantes?

Merci d'avance de votre éclairage.

4 réponses

DjiDji59430 Messages postés 4000 Date d'inscription samedi 19 avril 2008 Statut Membre Dernière intervention 28 février 2024 638
31 juil. 2015 à 00:15
0
Levecteur Messages postés 18 Date d'inscription mercredi 20 mars 2013 Statut Membre Dernière intervention 18 septembre 2018
31 juil. 2015 à 11:20
Bonjour DjiDji59430,

Merci de votre réponse à ma préoccupation,

Toutefois,je n'arrive pas à résoudre mon souci avec ce procédé,j'aimerais bien faire plus de précision si nécessaire. Merci de confirmer si ma question est difficile à cerner

Merci!
0
DjiDji59430 Messages postés 4000 Date d'inscription samedi 19 avril 2008 Statut Membre Dernière intervention 28 février 2024 638
31 juil. 2015 à 15:40
re

Envoyer un fichier test avec les resultats désirés et les explications necessaires a l'obtention de ces memes resultats
aller sur https://www.cjoint.com/ et remettre le lien obtenu
Crdmt
0
eriiic Messages postés 24562 Date d'inscription mardi 11 septembre 2007 Statut Contributeur Dernière intervention 29 février 2024 7 210
31 juil. 2015 à 17:16
Bonjour,

tu ne t'es pas trompé de fichier Djidji ?
Sélectionner A2:G4 et MFC :
=NB.SI($H2:$M2;A2)>0 

https://www.cjoint.com/c/EGFpqCTRvfT

eric
0
DjiDji59430 Messages postés 4000 Date d'inscription samedi 19 avril 2008 Statut Membre Dernière intervention 28 février 2024 638
31 juil. 2015 à 17:56
Bonjour Eriiic,

He oui, ma vue baisse et mes doigts deviennent fourchus !!!!

Crdmt
0
Levecteur Messages postés 18 Date d'inscription mercredi 20 mars 2013 Statut Membre Dernière intervention 18 septembre 2018
1 août 2015 à 12:07
Bonjour Djidji59430,

Merci de l'astuce pour obtenir le lien Cjoint, j'ignorais ce procédé.

Je crois que le second fichier qui a été proposé pourrait m'aider, seulement je ne comprend pas bien le principe de la formule =NB.SI($H2:$M2;A2)>0. j'avoue que je suis un peu égaré par l'inégalité >0. j'aimerais mieux comprendre et interpréter la formule pour l'appliquer. Merci de trouver ci-après le lien du fichier sur lequel je veux appliquer la mise en forme.

https://www.cjoint.com/c/EHbj0RVgNUX

Cdlt

Levecteur
0
eriiic Messages postés 24562 Date d'inscription mardi 11 septembre 2007 Statut Contributeur Dernière intervention 29 février 2024 7 210
1 août 2015 à 12:32
Bonjour,

c'était eric...
=NB.SI($H2:$M2;A2) compte le nombre de fois où T1 est inscrit dans P1:P6 et =NB.SI($H2:$M2;A2)>0 retourne VRAI si c'est >0. Dans ce cas ta MFC s'appliquera.

Pour ton tableau sélectionne B5:I30 et MFC :
=NB.SI($K5:$P5;B5)>0
Références Relatives & Absolues

eric
0
Levecteur Messages postés 18 Date d'inscription mercredi 20 mars 2013 Statut Membre Dernière intervention 18 septembre 2018
Modifié par Levecteur le 1/08/2015 à 13:58
Salut! Eric

Merci bien pour cet éclaircissement supplémentaire,
J'ai maintenant compris le principe de la formule et en plus l'importance de la différence des types de références en fonction du résultat escompté.

Merci encore de votre support,

Cdlt,

Levecteur
0