Formule de recherche

Résolu/Fermé
triflophil Messages postés 2 Date d'inscription mardi 28 juillet 2015 Statut Membre Dernière intervention 28 juillet 2015 - 28 juil. 2015 à 09:50
Vaucluse Messages postés 26495 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 8 avril 2022 - 28 juil. 2015 à 12:25
Bonjour à tous!
je n'arrive pas à trouver la solution à une recherche précise que voici.
J'ai un tableau contenant une colonne de chiffres (des kilomètres) je dois faire une synthèse de cette colonne dans un autre petit tableau en recherchant combien de ces cellules sont en dessous de 5kms, entre 6 et 20, entre 21 et 50, entre 51 et 200 et au dessus de 200
je crois qu'il est possible de faire ça avec une recherchev mais je n'y arrive pas...
ATTENTION je ne veux pas la somme seulement le nombre d'éléments dans chaque intervalle..
Merciiii

2 réponses

Vaucluse Messages postés 26495 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 8 avril 2022 6 285
Modifié par Vaucluse le 28/07/2015 à 09:57
Bonjour
ce n'est pas une formule de recherche qu'il vous faut
pour un champ de A1 àA1000 à adapter:

=NB.SI(A1:A1000;"<=5") (valable tous Excel)
=NB.SI(A1:A1000;">200")

et pour les fourchettes

à partir d'Excel 2007
=NB.SI.ENS(A1:A1000;">5";A1:A1000;"<=20")
et ainsi de suite pour les autres fourchettes

si Excel avant 2007
=SOMMEPROD((A1:A1000>=5)*(A1:A1000<20))

crdlmnt

Errare humanum est, perseverare diabolicum
0
triflophil Messages postés 2 Date d'inscription mardi 28 juillet 2015 Statut Membre Dernière intervention 28 juillet 2015
28 juil. 2015 à 12:05
Merci beaucoup!
simple que ça ;)
des fois on se fait des noeuds dans la tête pour rien
0
Vaucluse Messages postés 26495 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 8 avril 2022 6 285
28 juil. 2015 à 12:25
Pas de quoi...je passe le sujet en résolu
Bonne route
crdlmnt
0