Calculer le nombre de dates correspondant à un numéro de semaine [Résolu/Fermé]

Signaler
Messages postés
184
Date d'inscription
jeudi 23 août 2012
Statut
Membre
Dernière intervention
6 juillet 2020
-
Messages postés
184
Date d'inscription
jeudi 23 août 2012
Statut
Membre
Dernière intervention
6 juillet 2020
-
Bonjour,

Dans l'onglet "Date" colonne M, j'ai des dates du 01/01/2015 au 24/07/2015.

A partir d'un autre onglet je souhaite, calculer combien de dates correspondent à la semaine n°30

=SOMMEPROD((Date'!$M$11:$M$10000=NO.SEMAINE(I24)))

Résultat = 0 ??

Merci d'avance,

Excel 2010



5 réponses

Messages postés
184
Date d'inscription
jeudi 23 août 2012
Statut
Membre
Dernière intervention
6 juillet 2020
2
Merci pour vos réponses, mais toujours un résultat à zéro....

J'utilise sommeprod car en effet je cherche plusieurs conditions....

J'ai rajouté en colonne w (=NO.SEMAINE(M11) étirée au bas de la colonne)

Puis :

=SOMMEPROD((GAUCHE(Date'!$K$11:$K$10000;2)="PE")*(Date'!$R$11:$R$10000="OUI")*('Date'!$W$11:$W$10000=I24))

Résultat = 0

Les autres formules fonctionnent mais dés que je rajoute une recherche du numéro de semaine ....=problème
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 60511 internautes nous ont dit merci ce mois-ci

Messages postés
25429
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
24 octobre 2020
5 550
bonjour
et vous avez quoi en I24?
Messages postés
184
Date d'inscription
jeudi 23 août 2012
Statut
Membre
Dernière intervention
6 juillet 2020
2
Bonjour,

30 par exemple...j'ai même essayé une date 23/07/2015.
Messages postés
184
Date d'inscription
jeudi 23 août 2012
Statut
Membre
Dernière intervention
6 juillet 2020
2
Date étant un onglet....

=SOMMEPROD((GAUCHE('Date'!$K$11:$K$10000;2)="PE")*('Date'!$R$11:$R$10000="OUI")*('Date'!$W$11:$W$10000=I24))
Messages postés
25429
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
24 octobre 2020
5 550
(j'ai vu pour l'onglet.. mais un peu tard!)

Alors ça devrait fonctionner.Etes vous sur que dans la fourchette du n°de semaine, vous avez bien des données qui correspondent aux deux autres conditions de SOMME.PROD?
si oui, il faudrait si possible mettre à disposition un modèle de votre fichier sur:
https://www.cjoint.com/
et revenir ici coller le lien donné par le site
à vous lire
Messages postés
184
Date d'inscription
jeudi 23 août 2012
Statut
Membre
Dernière intervention
6 juillet 2020
2
Oui je vérifie quand même demain.....encore merci !

Je viens d'essayer à la maison, c'est vrai que cela fonctionne !!

Encore Merci ! à tous !
Messages postés
813
Date d'inscription
mardi 21 juillet 2015
Statut
Membre
Dernière intervention
20 mars 2018
215
Bonjour

Je pense que la formule

=NB(valeur1;valeur2;...

serait plus appropriée
Messages postés
938
Date d'inscription
jeudi 11 septembre 2008
Statut
Membre
Dernière intervention
16 octobre 2016
45
Alors la formaule SOMMEPROD() fait la somme des produits de 2 ou plusieurs matrices, avec optionellement des conditions.

Si l'on regarde votre formule vous c'est comme si vous multipliez le résultat par 0. Il faudrait plutot écrire : =SOMMEPROD((Date!$M$11:$M$10000=NO.SEMAINE(I24))*(1))

Ensuite concernant votre problème, je vous conseil plutot de crée une colonne N° desemaine (par exemple la colonne N) et d'utiliseer la formule NB.si()

=NB.SI(Date!$N:$N;NO.SEMAINE(I24)

Dites moi si ça à marcher pour vous.

--
  • Vous pouvez mettre en forme votre code grâce à la flèche en haut a droite de l'éditeur de texte.

Pensez mettre vos messages en [Résolu] et cliquer sur le + des conseil qui vous ont été utiles."
Messages postés
12787
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
24 octobre 2020
2 049
Bonjour

La fonction NO.SEMAINE ne fonctionne pas en matricielle

Le plus simple faire une colonne N avec la formule :
=NO.SEMAINE(M11) étirée au bas de la colonne

Dans la cellule où tu veux le nombre de jours de la semaine 30 :
=NB.SI(N11:N10000;30)

Cdlmnt
Via
Messages postés
1978
Date d'inscription
mercredi 27 juillet 2005
Statut
Membre
Dernière intervention
28 septembre 2020
817
Bonjour à tous,

Bon, le sujet est résolu, j'arrive après la bataille....

Voilà quand même une solution qui suppose que I24 contient une date que l'on utilise pour obtenir un N° de semaine.
Le principe est de trouver le 1er jour de la semaine associée à I24 et le dernier jour.
Le sommeprod() s'appuie alors sur ces 2 limites.
SOMMEPROD(--(Date!M11:M10000>=(NO.SEMAINE(I24;2)-1)*7+DATE(ANNEE(I24);1;1)-JOURSEM(DATE(ANNEE(I24);1;1);2)+1)*(Date!M11:M10000<=(NO.SEMAINE(I24;2)-1)*7+DATE(ANNEE(I24);1;1)-JOURSEM(DATE(ANNEE(I24);1;1);2)+7))

j'ai choisi le lundi comme point de départ d'une semaine.

cordialement
Messages postés
184
Date d'inscription
jeudi 23 août 2012
Statut
Membre
Dernière intervention
6 juillet 2020
2
Merci JvDo, c'est une sacré formule !

J'ai essayé d'indiquer en I24 soit 30 ou soit une date comme 24/07/2015 et cela fonctionne !