Formule attribuer points

Résolu/Fermé
Signaler
Messages postés
352
Date d'inscription
samedi 7 décembre 2013
Statut
Membre
Dernière intervention
21 mars 2021
-
Messages postés
352
Date d'inscription
samedi 7 décembre 2013
Statut
Membre
Dernière intervention
21 mars 2021
-
Bonjour a tous,

j'ai un tableau avec des mots "vrai", chaque colonne a un intitulé et un tableau "points" attribuer pour le résultat que je recherche.
explication: si "Vrai" en colonne T4 regarde tableau points et lui attribuer dans cellule definis.
je vous met un fichier : https://www.cjoint.com/c/EGvjbGqJOex

merci a tous

Cdlmnt



1 réponse

Messages postés
26397
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
19 janvier 2022
6 182
Bonjour

?????

votre formule, en AB10 dans le code INDEX ne peut pas trouver la position de VRAI alors que vous donnez une position de colonne constante (avec COLONNE(K10:P10)-10 qui est égal à 1 dans tous les cas

voyez avec:
=SI(NB.SI(K10:P10;VRAI)>=1;RECHERCHEV(INDEX($K$3:$P$3;EQUIV(VRAI;K10:P10;0));$AG$4:$AH$9;2;0);"")

et de plus en AC10, la valeur de COLONNE(R10:V10)done 8, supérieur au nombre de colonne du champ R3:V3!
voyez avec

=SI(NB.SI(R10:V10;VRAI)>=1;RECHERCHEV(INDEX($R$3:$V$3;EQUIV(VRAI;R10:V10;0));$AG$10:$AH$14;2;0);"")

et pour simplifier puisque vous êtes au moins sous Excel 2007

=SIERREUR(RECHERCHEV(INDEX($R$3:$V$3;EQUIV(VRAI;R10:V10;0));$AG$10:$AH$14;2;0);"")

valable pour tous types de formules depuis excel 2007 pour éviter les codes d'erreur:

=SIERREUR(formule;"")


crdlmnt
Errare humanum est, perseverare diabolicum
0
Messages postés
352
Date d'inscription
samedi 7 décembre 2013
Statut
Membre
Dernière intervention
21 mars 2021
2
Bonjour,
merci vaucluse pour les formules, je me met au travail.

Cdlmnt :)
0