Macro RechercheV Excel [Résolu/Fermé]

Signaler
-
 PPV_MNT -
Bonjour je cherche quelqu'un pour réaliser une macro :

Mon Problème :
J'effectue un certain nombre de commande à l'année pour ma boite. Je dispose d'un fichier Excel où j'inscris tout les bons de commandes. Pour ce faire je rajoute une feuille à chaque fois en copiant la feuille précédente ayant modèle prédéfini de mon bon de commande.

Le But de ma macro serait de faire la somme de tout les totaux de chaque commande passée dans l'année.
Bien évidement chaque commande ne contient pas le même nombre d'article ce qui décale la case "Total :" verticalement.
Les noms de mes commandes dépendent de la date à laquelle celle-ci à été faite :
type "XX-200715-XX" je ne peux donc en aucun cas connaitre le noms des prochaines feuille de mon fichier excel.

Je ne peux pas utiliser une simple fonction recherchev qui est très pratique lorsque l'on a une ou un nombre de feuilles défini.

La Fonction me permettant de trouver le total d'une commande est celle-ci :
=RECHERCHEV($C$7;'MA-170715-SG '!$E$12:$F$100;2;FAUX)

J'aimerais simplement effectuer la somme des recherchev pour chaque feuilles et cela pour autant de feuilles rajoutées que je le souhaite.

Je n'ai pas le temps d'apprendre le language pour programmer des macro.

C'est pourquoi je cherche l'aide de quelqu'un ayant les connaissances nécessaire à ce problème.

Cordialement

2 réponses

Messages postés
9645
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
6 janvier 2021
2 011
Bonjour

Est ce que dans ta feuille modèle tu as une cellule avec écrit un truc fixe du genre "TOTAL" et le total numérique quelque part dans la même ligne, positionné de la même façon par rapport à "TOTAL" ?
Ex. sur une feuille-facture, le mot "TOTAL" est en K100 et le montant est en M100, sur une autre 'TOTAL" est en K25 et le montant en M25, ...

Cdlmnt
Sur la feuille ou j'aimerais que la somme soit affichée le mot total est dans la cellule C7 et le montant doit arriver en D7.

Sur les autres feuilles Le mot total est toujours dans la colonne E mais a une ligne variable et le montant se situe dans la colonne F a la même ligne que le mot total
Messages postés
9645
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
6 janvier 2021
2 011
Un exemple
http://www.cjoint.com/c/EGuo7pCS1DG

Cdlmnt
Merci beaucoup pour ton aide rapide et efficace c'est exactement ce qu'il me fallait !