La Fonction RECHERCHEV

[Fermé]
Signaler
Messages postés
14
Date d'inscription
mardi 7 juillet 2015
Statut
Membre
Dernière intervention
14 avril 2016
-
Messages postés
589
Date d'inscription
mardi 7 avril 2015
Statut
Membre
Dernière intervention
23 juillet 2015
-
j'aimerai comprendre pourquoi la présence du chiffre 1 dans une formule quand on utilise la fonction recherchev par exemple:
= (1+ RECHERCHEV...

1 réponse

Messages postés
589
Date d'inscription
mardi 7 avril 2015
Statut
Membre
Dernière intervention
23 juillet 2015
57
Bonjour,

ça dépend de la structure de ton fichier. Nous faut la structure avec la formule, par exemple on peut l'utiliser pour dire que si la recherche marche et que le résultat est numérique. On voudrait par la suite l'additionner par 1 soit un résultat de 10 +1 = 11

Cordialement,
Excel-Worker
Messages postés
14
Date d'inscription
mardi 7 juillet 2015
Statut
Membre
Dernière intervention
14 avril 2016

Merci de votre prompte reponse. Cette formule je l'ai eu dans cet exemple tiré du net. surement que vous l'avez vu aussi. il s'agissait de trouver CATTC et le COM (commission0
Vendeur Pays CA HT CA TTC Com
Legrand France 25 000
Paoli Italie 49 500
Chasseney France 22 750
De la garde Italie 18 000
Parlois Italie 120 000
Legrand Espagne 84 300
Paoli Espagne 21 200
Aulin France 98 700

en ayant comme base ceci:
Pays TVA Taux Com
France 19,60% 5%
Espagne 21% 4%
Italie 15% 3,5%

Voici donc la formule à insérer dans la cellule D2 : =C2*(1+RECHERCHEV(B2;Source;2;FAUX))
j'ai essayé de comprendre mais la présence du chiffre 1 me bloque dans la compréhension. pourquoi sa présence?
Messages postés
589
Date d'inscription
mardi 7 avril 2015
Statut
Membre
Dernière intervention
23 juillet 2015
57 >
Messages postés
14
Date d'inscription
mardi 7 juillet 2015
Statut
Membre
Dernière intervention
14 avril 2016

Partant du départ, au début pour cet exemple on a utilisé =SI(B2="France";C2*1.196;SI(B2="Espagne";C2*1.21;SI(B2="Italie";C2*1.15;"?"))) qui nous permettait d'avoir le CA TTC puis =SI(B2="France";C2*0.05;SI(B2="Espagne";C2*0.04;SI(B2="Italie";C2*0.035;"?"))) pour la com.

Le problème posé : si la TVA change, les calculs vont être fatiguant, que faire ?

On a donc décidé de créer un tableau qu'on nomme Source à part en y mettant les pays avec la tva et com (différente pour chaque pays).

Du coup par la suite avec ta formule, si on fait recherchev... on obtient 19.6% TVA qu'on avait mis sur notre tableau à part. On veut avoir notre résultat avec la TVA du coup on fait 1+19.6% = 1.196 (valeur standard) * 25000 = ... Pour avoir notre nouveau CA TTC, c'est simple non ?

Cordialement,
Excel-Worker
Messages postés
14
Date d'inscription
mardi 7 juillet 2015
Statut
Membre
Dernière intervention
14 avril 2016

je vois mais pourquoi 1.196 est ce que cela equivquat à 19.60% et 1.21 à 21%....
Messages postés
589
Date d'inscription
mardi 7 avril 2015
Statut
Membre
Dernière intervention
23 juillet 2015
57 >
Messages postés
14
Date d'inscription
mardi 7 juillet 2015
Statut
Membre
Dernière intervention
14 avril 2016

dans cet exercice la TVA était à 19.6% soit 0.196 du coup faut rajouter un 1 pour que le montant soit bon, ça aurait très bien pu être 5% ou autres.

Exact 1.21 pour 21% en TVA ou commission.

Cordialement,
Excel-Worker