Fonction si/ou imbriquées avec cellules vides [Résolu/Fermé]

Signaler
Messages postés
7
Date d'inscription
dimanche 26 avril 2015
Statut
Membre
Dernière intervention
27 août 2015
-
Messages postés
7
Date d'inscription
dimanche 26 avril 2015
Statut
Membre
Dernière intervention
27 août 2015
-
Bonsoir à tous,

Malgré toutes mes recherches je ne trouve qu'une partie de solution à mon problème.
Dans un tableau, je saisi des accords ou refus avec des dates liées.
Les accords ou bien refus son renseignés comme ceci : "A" pour accord et "R" pour refus (super compliqué).
Deux colonnes sont renseignées de cette façon (D et F).
Enfin une autre colonne (H) elle contient des dates (qui sont saisies aussi manuellement).
Mon but est de trouver une formule à insérer dans la colonne C qui répondrait à ces conditions :
Si seulement une des deux cellules D2 ou F2 contient "R" alors C2 affichera "R".
Mais il se peut qu'une seule des cellules soit renseignées ; D2 ou F2 peut être vide.
Ensuite si une affiche "A", et l'autre "R", C2 doit afficher "R".

Si une seule affiche "A" et l'autre est vide, ou que les deux affichent "A", C2 affichera "A" ; par contre si sur la même ligne, une date est renseignée dans la colonne H, alors C2 affichera "R".
Enfin rien car ce n'est pas si simple en tout cas pour moi, si rien n'est saisi C2 doit rester vide car dans les formules SI(OU( que j'avais utilisé, je me retrouvais avec des "A" qui répondait à la valeur faux ou vrai de mes conditions SI.

Si quelqu'un à la solution ou une piste, je suis plus que preneur.

Merci d'avance pour votre lecture attentive. Le lien de mon fichier test est en bas de message.

Guillaume


http://www.cjoint.com/c/EFDunK4PPwx

1 réponse

Messages postés
3334
Date d'inscription
samedi 20 juillet 2013
Statut
Membre
Dernière intervention
9 décembre 2016
497
Bonsoir,

Essaie avec :
=SI(OU(D2="R";F2="R";H2<>"");"R";SI(OU(D2="A";F2="A");"A";""))

A+
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 76687 internautes nous ont dit merci ce mois-ci

Messages postés
7
Date d'inscription
dimanche 26 avril 2015
Statut
Membre
Dernière intervention
27 août 2015

Bonsoir
Quelle réponse rapide et comment dire MERCIIIIIII cela fonctionne à merveille. Je comprend bien la formule mais à quoi servent les <> avec H2 ? je ne comprend pas leur signification autre que sup et inf.
Déjà un grand merci à toi.
Messages postés
3334
Date d'inscription
samedi 20 juillet 2013
Statut
Membre
Dernière intervention
9 décembre 2016
497 >
Messages postés
7
Date d'inscription
dimanche 26 avril 2015
Statut
Membre
Dernière intervention
27 août 2015

H2<>"" se traduit par H2 différent de vide, ce qui pourrait aussi s'écrire NON(ESTVIDE(H2)).

A+
Messages postés
7
Date d'inscription
dimanche 26 avril 2015
Statut
Membre
Dernière intervention
27 août 2015

merci pour l'info ; je connaissais l'autre écriture mais pas celle-ci ; je comprend mieux la syntaxe de ta formule. Merci encore pour ton aide. Je clos le sujet.