Utiliser le texte d'une cellule dans une formule [Résolu/Fermé]

Signaler
Messages postés
95
Date d'inscription
mardi 3 décembre 2013
Statut
Membre
Dernière intervention
13 janvier 2019
-
Messages postés
95
Date d'inscription
mardi 3 décembre 2013
Statut
Membre
Dernière intervention
13 janvier 2019
-
Bonjour alors voila j'utilise cette fonction: =rechercheV(A2;JANVIER!A1;D10;2)
sauf que dans la cellule A1 j'ai JANVIER d'écris j'aimerai que si je change de mois dans cette cellule la feuille utilisée par ma fonction s'adapte. Exemple je met juillet dans A1 et ma rechercheV cherche dans mon tableau de la feuille de juillet et pas janvier... sauf que je vois pas comment faire. Aidez moi svp!!
Merci d'avance

1 réponse

Messages postés
25188
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
20 juillet 2020
5 372
Bonjour
1°) je ne pense pas que vous écriviez JANVIER!A1;D10 mais plutôt JANVIER!A1:D10, non?
2°) la formule:
=RECHERCHEV(A2;INDIRECT(A1&"!A1:D10");2)
si vous n'avez pas de blanc dans les noms de feuille en A1

crdlmnt
5
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 57860 internautes nous ont dit merci ce mois-ci

Messages postés
95
Date d'inscription
mardi 3 décembre 2013
Statut
Membre
Dernière intervention
13 janvier 2019
45
En effet je me suis trompée en tapant la formule sur le forum.
Merci beaucoup!!!!! ça marche du tonner!

Cordialement