Utiliser la valeur d'une cellule comme coordonnée dans formule [Résolu/Fermé]

Signaler
Messages postés
7
Date d'inscription
mardi 2 juillet 2013
Statut
Membre
Dernière intervention
12 septembre 2013
-
Messages postés
26108
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
24 juillet 2021
-
Bonjour,
Mon problème se présente ainsi:

J'assure le suivi et la consommation de lances O².
Dans mon classeur j'ai 2 feuilles:
-Suivi
-Lances
la première liste chaque occurrence d'utilisation de la lance (plusieurs lignes par lance)
la deuxième est un résumé de chaque lance (une ligne par lance)

Dans "Lances", du coup j'ai une colonne Q avec la première ligne correspondant à la lance et R pour la dernière occurrence de la même lance (R4=Q5-1 pour faire simple).
Ensuite j'utilise la fonction INDIRECT pour certaines valeurs simples (comme le numéro de la lance et sa référence).

Mon problème commence lorsque je dois faire par exemple la somme de toutes les occurrences.

J'aimerai pouvoir faire quelque chose du genre
D2=SOMME(Suivi!$T(numéro de la ligne que l'on retrouve en Q2 sur la feuille Lances)-Suivi!$U(numéro de la ligne que l'on retrouve en R2 sur la feuille Lances)-[@VO²)

J'ai essayé avec les fonction INDIRECT et ADRESSE mais mis à part erreur d'écriture, je n'ai pas réussi.

Merci d'avance.
Je suis sous Office 2010.



4 réponses

Messages postés
1263
Date d'inscription
vendredi 23 avril 2004
Statut
Membre
Dernière intervention
15 mai 2017
568
Bonjour,

Pour (Suivi!$T(numéro de la ligne que l'on retrouve en Q2) essaie

INDIRECT("$T"&Q2)

et ajuste le reste de ta formule en rapport.

Cordialement.
Messages postés
26108
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
24 juillet 2021
5 993
Bonjour
ce qui est curieux dans votre formule c'est le signe - entre T et U
essayez avec:

=SOMME(INDIRECT("suivi!T"&Lance!Q2&":U"&Lance!R2))..........

crdlmnt
Messages postés
7
Date d'inscription
mardi 2 juillet 2013
Statut
Membre
Dernière intervention
12 septembre 2013

Merci beaucoup.

J'ai modifié mon message, pour précision:
Le $T est sur la feuille "Suivi" et Q2 est sur "Lances".
Comment introduire cela dans la formule ? (si c'est possible)
Merci

[EDIT]
Ma formule est pour faire la différence entre la longueur initiale et la longueur finale de la lance et voir la longueur consommée.
La formule remonte #REF!
J'ai simplifier mon tableau pour partir de la case ou il y a la longueur consommé pour tout les autres calculs donc la formule se simplifient à
O2=SOMME((suivi T et Lances Q2)-(suivi U et lances R2))
Qu'elle est l'écriture de la formule ?

Avec
O2=SOMME(INDIRECT("Suivi!$T"&Q2-"Suivi!$U"&R2))
La formule remonte #VALEUR!

Merci
Messages postés
7
Date d'inscription
mardi 2 juillet 2013
Statut
Membre
Dernière intervention
12 septembre 2013

C'est bon !!!
J'ai marqué ainsi:
O2=SOMME(INDIRECT("Suivi!$T"&[@Début])-(INDIRECT("Suivi!$U"&[@Fin])))

[@Début]&[@Fin] remplacent mes Q2 et R2.

Merci beaucoup à vous pour votre aide :)
Bonne journée
Messages postés
26108
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
24 juillet 2021
5 993
Bien c'est l'essentiel, mais vous n'avez pas besoin piur ce calcul du code SOMME puisque vous utilisez des cellules uniques
O2=INDIRECT("Suivi!$T"&[@Début])-(INDIRECT("Suivi!$U"&[@Fin])
devrait suffire
Bonne route