Utiliser la valeur d'une cellule comme coordonnée dans formule

Résolu/Fermé
RyseSorel
Messages postés
7
Date d'inscription
mardi 2 juillet 2013
Statut
Membre
Dernière intervention
12 septembre 2013
- Modifié par RyseSorel le 12/09/2013 à 09:43
Vaucluse
Messages postés
26495
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 avril 2022
- 12 sept. 2013 à 11:52
Bonjour,
Mon problème se présente ainsi:

J'assure le suivi et la consommation de lances O².
Dans mon classeur j'ai 2 feuilles:
-Suivi
-Lances
la première liste chaque occurrence d'utilisation de la lance (plusieurs lignes par lance)
la deuxième est un résumé de chaque lance (une ligne par lance)

Dans "Lances", du coup j'ai une colonne Q avec la première ligne correspondant à la lance et R pour la dernière occurrence de la même lance (R4=Q5-1 pour faire simple).
Ensuite j'utilise la fonction INDIRECT pour certaines valeurs simples (comme le numéro de la lance et sa référence).

Mon problème commence lorsque je dois faire par exemple la somme de toutes les occurrences.

J'aimerai pouvoir faire quelque chose du genre
D2=SOMME(Suivi!$T(numéro de la ligne que l'on retrouve en Q2 sur la feuille Lances)-Suivi!$U(numéro de la ligne que l'on retrouve en R2 sur la feuille Lances)-[@VO²)

J'ai essayé avec les fonction INDIRECT et ADRESSE mais mis à part erreur d'écriture, je n'ai pas réussi.

Merci d'avance.
Je suis sous Office 2010.



A voir également:

4 réponses

Vaucluse
Messages postés
26495
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 avril 2022
6 266
12 sept. 2013 à 09:59
Bonjour
ce qui est curieux dans votre formule c'est le signe - entre T et U
essayez avec:

=SOMME(INDIRECT("suivi!T"&Lance!Q2&":U"&Lance!R2))..........

crdlmnt
0