Compter le nombre de caracteres identiques dans une meme cellule

[Résolu/Fermé]
Signaler
-
 spqr79 -
Bonjour,
Dans un tableur open office Calc, je voudrais compter le nombre de fois qu'apparait le signe ; dans les colonnes d'une même ligne.
Un utilisant la formule NB.SI cela fonctionne sauf si j'ai plusieurs fois le signe ; dans une même cellule : la cellule n'est alors pas comptabilisée.
Comment adapter la formule?
Merci d'avance pour votre aide

1 réponse

Messages postés
2497
Date d'inscription
mercredi 3 février 2010
Statut
Membre
Dernière intervention
19 octobre 2021
1 001
Bonjour,
On remplace le caractère par rien et on compte.
Dans une cellule unique
NBCAR(A2)-NBCAR(SUBSTITUE(A2;";";"")
Dans plusieurs cellules d'une ligne:
=SOMMEPROD((NBCAR(A2:M2)-NBCAR(SUBSTITUE(A2:M2;";";""))))
Bonjour tongtong.
Désolé de ne pas vous avoir répondu plus tôt : pour cause de déplacement je viens juste de voir votre réponse.
C'est très clair et cela fonctionne : merci beaucoup!