Somme si ens avec critere de liste de nom défini [Résolu/Fermé]

Signaler
Messages postés
10
Date d'inscription
vendredi 10 août 2012
Statut
Membre
Dernière intervention
7 juin 2015
-
Messages postés
10
Date d'inscription
vendredi 10 août 2012
Statut
Membre
Dernière intervention
7 juin 2015
-
Bonjour!

Quelqu'un peut-il m'aider?

Je souhaiterais inclure dans une formule somme.si.ens, un critère avec une liste (nom défini).
Que le critère soit ; fais moi la somme de telle colonne si dans telle autre colonne la valeur correspond à une des valeurs qu'il y a dans la liste.
Je vous joins un fichier exemple car je ne sais pas si je m'explique bien! :
https://www.cjoint.com/c/EFhmxBWtGM8

encore merci.

3 réponses

Messages postés
25768
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
26 janvier 2021
5 740
Bonjour
je ne crois pas que SOMME.SI.ENS puisse résoudre ce problème, essayez plutôt:
=SOMMEPROD((SOMME.SI(C2:C5;liste;D2:D5))*1)

crdlmnt
Messages postés
12908
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
26 janvier 2021
2 109
Bonjour

Une possibilité avec une fonction personnalisée, à mettre dans un module (ALT+F11 pour ouvrir Editeur VBA puis Insertion puis Module, copier-coller la fonction dans la page
Function decompte(p1 As Range, p2 As Range, base As Range)
col = p2.Column
For Each cell In p1
n = Application.WorksheetFunction.CountIf(base, cell)
If n > 0 Then Total = Total + Cells(cell.Row, col)
Next
decompte = Total
End Function


La fonction s'utilise ensuite comme toute fonction excel
Syntaxe :
=decompte (plage des lettres;plage des chiffres;plage de référence)
ex : =decompte(C2:C10;D2:D10;A2:A5)

Cdlmnt
Via
Messages postés
10
Date d'inscription
vendredi 10 août 2012
Statut
Membre
Dernière intervention
7 juin 2015

merci pour pour la formule decompte! elle fonctionne, mais j'imagine que je ne peux pas l'inclure dans ma formule somme.si.ens, car j'ai beaucoup plus de critères et celui-ci est un de plus.

encore merci!
Messages postés
25768
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
26 janvier 2021
5 740
Messages postés
10
Date d'inscription
vendredi 10 août 2012
Statut
Membre
Dernière intervention
7 juin 2015

ce lien me renvoie à cette réponse :
=SOMMEPROD((SOMME.SI(C2:C5;liste;D2:D5))*1)

elle fonctionne effectivement mais moi je souhaitais crééer cette formule dans un somme si ens...
Messages postés
25768
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
26 janvier 2021
5 740
Comme déjà dit, je crains que ce ne soit pas possible... SOMME.SI ou NB.SI à priori n'acceptent pas directement les matricielles.
par contre, si vous avez d'autres arguments à ajouter, SOMMEPROD les acceptent sans problème:
=SOMMEPROD((SOMME.SI(C2:C5;liste;D2:D5))*(champ1=arg1)*(Champ2=Arg2))
autant que vous voulez.
a condition que tous les champs soient limités par des N° de ligne et qu'ils aient la même hauteur.

crdlmnt)
Messages postés
10
Date d'inscription
vendredi 10 août 2012
Statut
Membre
Dernière intervention
7 juin 2015

merci beaucoup !
est-ce que les champs peuvent être des listes de noms incluants une formule 'décaler"?
... je vais essayer de toutes manières,
je remercie tout le monde!!!