Somme avec plusieurs critères date et texte

Fermé
josp38
Messages postés
3
Date d'inscription
samedi 30 mai 2015
Statut
Membre
Dernière intervention
30 mai 2015
- 30 mai 2015 à 10:28
josp38
Messages postés
3
Date d'inscription
samedi 30 mai 2015
Statut
Membre
Dernière intervention
30 mai 2015
- 30 mai 2015 à 14:25
Bonjour,
J'ai un tableau Excel dans lequel je classe des informations texte selon une date et je souhaiterais additionner le nombre de fois ou se même texte reviens dans une année au choix car le ficher est sur plusieurs années.
J'ai fait un menu déroulant ( validation de données, liste) dans lequel je choisi l'année pour le calcul.

exemple:

12/03/2003 pierre
25/06/2003 pierre
15/07/2003 table
02/05/2004 pierre

Et la donc je souhaiterais que la formule me compte le nombre de fois ou le mot " pierre " est apparu en 2003. Soit pour cette exemple que le résultat soit : 2.

Merci d'avance.

4 réponses

via55
Messages postés
13726
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
6 juillet 2022
2 445
30 mai 2015 à 10:51
Bonjour

En supposant les dates en A2:A5, les noms en B2:B5, la liste déroulante d'années en D1, le texte recherché en D2,
formule dans la cellule de ton choix pour avoir le décompte :
=SOMMEPROD((ANNEE(A2:A5)=D1)*(B2:B5=D2))

Cdlmnt
Via
0
josp38
Messages postés
3
Date d'inscription
samedi 30 mai 2015
Statut
Membre
Dernière intervention
30 mai 2015

30 mai 2015 à 11:16
Merci pour la réponse très rapide et de plus au top de mes attentes.
Voici à l'aide de ta formule la mienne:
=SI(E2="";"";SOMMEPROD((ANNEE(suivi!A2:A1000)=$E$2)*(suivi!B2:B1000="vl")))

Alors maintenant que cette formule marche j'ai une dernière demande.

En face de chaque texte j'ai une durée de réalisation en format heure ( 00:00:00) et je souhaiterai dans une autre case calculer le temps total passé en une année sans se soucier du texte mais juste de la date

exemple:

12/03/2003 pierre 02:30:00
25/06/2003 pierre 00:30:00
15/07/2003 table 01:15:00
02/05/2004 pierre 10:20:00

la le résultat que j'attend pour l'année 2003 est 04:15:00.

Merci.
0
via55
Messages postés
13726
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
6 juillet 2022
2 445
30 mai 2015 à 12:01
Re,

En supposant les heures en colonne C :
=SI(E2="";"";SOMMEPROD((ANNEE(suivi!A2:A1000)=$E$2)*(suivi!C2:C1000)))
Ne pas oublier de mettre la cellule de résultat en format personnalisé [h]:mm:ss de manière à autoriser un total supérieur à 24 h

Cdlmnt
Via
0
josp38
Messages postés
3
Date d'inscription
samedi 30 mai 2015
Statut
Membre
Dernière intervention
30 mai 2015

30 mai 2015 à 14:25
merci encore pour cette formule.
bonne journée
0