Fusionner lignes en additionnant cellules

Fermé
Alouce Messages postés 34 Date d'inscription vendredi 28 mars 2008 Statut Membre Dernière intervention 8 juin 2016 - 1 mai 2015 à 22:09
via55 Messages postés 13982 Date d'inscription mercredi 16 janvier 2013 Statut Membre Dernière intervention 6 décembre 2022 - 2 mai 2015 à 16:55
Bonjour,

Dans mon fichier excel (image ci-jointe), je souhaiterais fusionner deux lignes tout en additionnant le contenu de deux cellules.
Je m'explique, je veux fusionner les lignes où les magasins sont les mêmes, à la même date, tout en additionnant le contenu des cellules "poids" et "colis" (exemple : fusionner les lignes 2, 3 et 4, en additionnant les cellules E2, E3 et E4 ensemble, puis les cellules G2, G3 et G4 ensemble).

Est-ce possible ? Existe-t-il une formule ? (car je ne veux pas de "macro")

Merci beaucoup !

3 réponses

via55 Messages postés 13982 Date d'inscription mercredi 16 janvier 2013 Statut Membre Dernière intervention 6 décembre 2022 2 530
1 mai 2015 à 23:34
Bonjour Alouce

C'est toujours mieux de joindre un fichier plutôt qu'un image, ça évite d'avoir à retaper toutes les infos !
Mais bon, voilà une possibilité (en rajoutant 2 colonnes) :
https://www.cjoint.com/?0EbxWDyNAd9

Cdlmnt
Via
0
Alouce Messages postés 34 Date d'inscription vendredi 28 mars 2008 Statut Membre Dernière intervention 8 juin 2016 2
2 mai 2015 à 15:22
Merci pour ta réponse. Je suis désolée, je ne savais pas comment joindre mon fichier.
Voici mon fichier : https://www.cjoint.com/c/EEcpI6jlwGY

Que signifie les cellules "42097CD01" ? Concernant la colonne J, je dois numéroter à la main les premières occurrences ?

Que dois-je modifier dans la formule pour l'adapter à mon fichier ? Ce qu'il y a en gras ?

=SI($D2<>"";SOMME.SI.ENS($'Tableau initial'.E$1:E$1048576;$'Tableau initial'.$B$1:$B$1048576;$'Tableau fusion'.$B2;$'Tableau initial'.$D$1:$D$1048576;$'Tableau fusion'.$D2);"")
0
via55 Messages postés 13982 Date d'inscription mercredi 16 janvier 2013 Statut Membre Dernière intervention 6 décembre 2022 2 530
2 mai 2015 à 16:55
Bonjour Alouce

Les formules appliquées à ton fichier :
https://www.cjoint.com/?0Ecq71PI3xQ

Dans la colonne I on concatène par formule la date et le magasin, la date est retournée sous la forme numéro de série (celui qu'utilise excel pour les dates 42038 correspond au3/02/2015 car c'est le 42038eme jour depuis la 1er janvier 1900)
Dans la colonne J la formule décompte automatiquement seulement les 1eres concaténation date/magasin rencontrées
Tu ne dois rien écrire à la place des formules, seulement les étirer au bas de tes colonnes si la liste est plus longue.
Dans la Sheet2 les formules font maintenant référence à Sheet1 et Sheet2
Idem étirer les formules vers le bas si nécessaire, dès qu'on dépasse le nombre d'occurences trouvées en colonne J de Sheet1 les formules renvoient du vide au lieu de données

Cdlmnt
Via

0