Problème ajout nom de domaine sur serveur debian

Fermé
konova - 23 avril 2015 à 13:30
 konova - 23 avril 2015 à 16:00
Bonjour,

J'ai acheté un nom de domaine sur ovh.com et je voudrai le rajouter sur mon serveur kimsuffi. J'ai suivi ce tuto http://mondedie.fr/viewtopic.php?id=5946 et quand je fais les vérficiations des fichiers de configurations je n'ai aucune erreur. Cependant, quand je veux accéder à mon nom de domaine j'ai un chargement infini. J'ai bien rajouté aussi mes serveurs DNS sur le manager ovh. Est-ce que quelqu'un peut m'aider?

Merci par avance.


5 réponses

Judge_DT Messages postés 29395 Date d'inscription vendredi 5 février 2010 Statut Modérateur Dernière intervention 23 octobre 2021 9 633
23 avril 2015 à 15:22
Salut,

Bon déjà :

Ton serveur dédié tourne sous Debian tout seul? Avec un panneau d'administration ?

Sur ton nom de domaine, quelles sont les serveurs DNS qui lui sont attitrés ?

Si ce sont ceux d'OVH, tu ne devrais pas avoir besoin du tutoriel que tu nous cites, puisque tu utilises déjà ceux de OVH.

Le tutoriel que tu cites, lui, te permet de créé tes propres serveurs DNS sur ta propre machine.
0
Mon serveur est un serveur dédié kimsuffi sous Debian GNU/Linux 7.7. J'ai un serveur plex dessus et apache et je voudrais remplacer l'ip de mon serveur par le nom de domaine que j'ai acheté. J'ai remplacé les DNS d'ovh par ceux de mon serveur kimsuffi (comme indiqué dans le tuto).
0
Judge_DT Messages postés 29395 Date d'inscription vendredi 5 février 2010 Statut Modérateur Dernière intervention 23 octobre 2021 9 633
23 avril 2015 à 15:29
Ok.

Si tu essaies de faire un "traceroute" ou un "ping" vers ton nom de domaine, quelle adresse IP y répond ?

Peux-tu préciser le nom de domaine, pour être certains qu'il soit bien configuré ou que les informations soient bien communiqués aux autres serveurs DNS ?
0
Le nom de domaine est corde.info
0
Judge_DT Messages postés 29395 Date d'inscription vendredi 5 février 2010 Statut Modérateur Dernière intervention 23 octobre 2021 9 633
23 avril 2015 à 15:40
ça ne m'étonne même pas.

Si tu spécifies dans les "nameserver" -> ns.kimsufi.com ça ne fonctionnera pas.

Le serveur DNS est celui qui se trouve sur TA machine et non celui de Kimsufi.

Par conséquent, il faut retirer le serveur DNS de Kimsufi, dans un premier temps, puisque lui ne gère sûrement pas la zone du domaine.

Ensuite, ton serveur qui est à l'adresse : ns364590.ip-91.121.209.eu, ne réponds pas non plus du côté DNS, ce qui veut dire qu'aucun serveur DNS ne fonctionne de son côté, ou alors un pare-feu empêche de communiquer vers ce serveur DNS.
0
Merci beaucoup pour tes réponses. Désolé je suis vraiment débutant dans les DNS. J'ai mis ns.kimsufi.com dans les nameserver parce que c'est ce qui était indiqué sur le tuto je crois (dns secondaire). En gros, là j'ai mis dns primaire ns364590.ip-91-121-209.eu et secondaire ns.kimsufi.com. Pour le firewall j'ai des régles iptables. Je dois regarder à quel niveau pour vérifier que ce n'est pas bloqué?


Merci encore
0
Judge_DT Messages postés 29395 Date d'inscription vendredi 5 février 2010 Statut Modérateur Dernière intervention 23 octobre 2021 9 633
23 avril 2015 à 15:55
Salut,

En vérifiant que le port utiliser par ton serveur DNS n'est pas bloquer en "input"

En toute théorie, c'est le port "53" en UDP/TCP selon la configuration.

Si ils ne sont pas ouvert, tu pourras le faire avec les commandes suivantes.

iptables -A INPUT -p udp -m udp --dport 53 -j ACCEPT
iptables -A INPUT -p tcp -m tcp --dport 53 -j ACCEPT
0

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
Effectivement je n'avais pas ouvert ce port donc déjà un problème en moins.
0